您的位置:首页 > 其它

CODEVS 1230 元素查找

2017-12-04 17:36 429 查看


题目描述 Description

给出n个正整数,然后有m个询问,每个询问一个整数,询问该整数是否在n个正整数中出现过。

输入描述 Input Description

第一行两个整数 n 和m。

第二行n个正整数(1<=n<= 100000)

第三行m个整数(1<=m<=100000)

输出描述 Output Description

一共m行,若出现则输出YES,否则输出NO

样例输入 Sample Input

4 2

2 1 3 4

1 9

样例输出 Sample Output

YES

NO

数据范围及提示 Data Size & Hint

所有数据都不超过10^8

c++自带的STL库

[cpp] view
plain c

#include<iostream>
#include<cstdio>
#include<set>
using namespace std;
#define maxn 100000
int main()
{
int n,m;
int a,b;
set<int>s;
scanf("%d %d",&n,&m);
for(int i=1;i<=n;i++)
{
scanf("%d",&a);
s.insert(a);
}
for(int j=1;j<=m;j++)
{
scanf("%d",&b);
if(s.count(b)==1)
printf("YES\n");
else
printf("NO\n");
}
return 0;
}


insert() 在集合中插入元素,count() 返回某个值元素的个数。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: