您的位置:首页 > 理论基础 > 数据结构算法

3344 数据结构实验之二叉树五:层序遍历

2017-11-11 19:32 399 查看
数据结构实验之二叉树五:层序遍历

Time Limit: 1000MS Memory Limit: 65536KB

Problem Description

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立二叉树并求二叉树的层次遍历序列。

Input

 输入数据有多行,第一行是一个整数t (t<1000),代表有t行测试数据。每行是一个长度小于50个字符的字符串。

Output

 输出二叉树的层次遍历序列。

Example Input

2
abd,,eg,,,cf,,,
xnl,,i,,u,,


Example Output

abcdefg
xnuli


#include <bits/stdc++.h>

using namespace std;

char st[52];
int k;
struct node
{
char data;
struct node *l, *r;
};

struct node *creat()
{
struct node *root;
if(st[++k]==',')
{
root = NULL;
}
else
{
root = new struct node;
root ->data = st[k];
root ->l = creat();
root ->r = creat();
}
return root;
}

void show(struct node *root)
{
struct node *tree[110];
int i=0,j=0;
tree[i++] = root;
while(i>j)
{
if(tree[j])
{
printf("%c",tree[j]->data);
tree[i++] = tree[j] ->l;
tree[i++] = tree[j] ->r;
}
j++;
}
cout << endl;
}

int main()
{
int t;
struct node *root;
scanf("%d",&t);
while(t--)
{
scanf("%s",st);
k = -1;
root = creat();
show(root);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: