您的位置:首页 > 其它

Halloween Costumes LightOJ - 1422 区间dp

2017-11-09 16:45 281 查看
Gappu has a very busy weekend ahead of him. Because, next weekend is Halloween, and he is planning to attend as many parties as he can. Since it's Halloween, these parties are all costume parties, Gappu always selects his costumes in such a way that it blends
with his friends, that is, when he is attending the party, arranged by his comic-book-fan friends, he will go with the costume of Superman, but when the party is arranged contest-buddies, he would go with the costume of 'Chinese Postman'.
Since he is going to attend a number of parties on the Halloween night, and wear costumes accordingly, he will be changing his costumes a number of times. So, to make things a little easier, he may put on costumes one over another (that is he may wear the
uniform for the postman, over the superman costume). Before each party he can take off some of the costumes, or wear a new one. That is, if he is wearing the Postman uniform over the Superman costume, and wants to go to a party in Superman costume, he can
take off the Postman uniform, or he can wear a new Superman uniform. But, keep in mind that, Gappu doesn't like to wear dresses without cleaning them first, so, after taking off the Postman uniform, he cannot use that again in the Halloween night, if he needs
the Postman costume again, he will have to use a new one. He can take off any number of costumes, and if he takes off
k of the costumes, that will be the last k ones (e.g. if he wears costume
A before costume B, to take off A, first he has to remove
B).

Given the parties and the costumes, find the minimum number of costumes Gappu will need in the Halloween night.

Input
Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case starts with a line containing an integer N (1 ≤ N ≤ 100) denoting the number of parties. Next line contains
N integers, where the ith integer
ci (1 ≤ ci ≤ 100)
denotes the costume he will be wearing in party
i. He will attend party 1 first, then party 2, and so on.

Output
For each case, print the case number and the minimum number of required costumes.

Sample Input
2

4

1 2 1 2

7

1 2 1 1 3 2 1

Sample Output
Case 1: 3

Case 2: 4

这道题找对转移方程真的是不容易,我仅仅思考到了要逆推,以及再i个点穿的衣服再后面不用是直接+1,在后面用的情况没有想到ORZ.
如用再i的后面用了i这一件衣服,也就是说,i这一件衣服并没有及时的脱去,而是等到了k这个点的时候直接脱去【i+1,k-1】这一身衣服然后进去,这时候状态转移方程就有了。

还是要多练习啊,套路多了就想得快做得快

#include<bits/stdc++.h>
using namespace std;
const int M=120;
int dp[M][M];
int s[M];
int main()
{
int t,kase=1;
scanf("%d",&t);
while(t--)
{
int n;
memset(dp,0,sizeof(dp));
scanf("%d",&n);
for(int i=1; i<=n; i++)
{
scanf("%d",&s[i]);
}
for(int i=n; i>=1; i--)
{
dp[i][i]=1;
for(int j=i+1; j<=n; j++)
{
dp[i][j]=dp[i+1][j]+1;
for(int k=i+1; k<=j; k++)
{
if(s[i]==s[k])
{
dp[i][j]=min(dp[i][j],dp[i+1][k-1]+dp[k][j]);
}
}

}
}
printf("Case %d: %d\n",kase++,dp[1]
);
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: