您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之二叉树二:遍历二叉树

2017-11-03 11:20 274 查看
数据结构实验之二叉树二:遍历二叉树

Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic

Problem Description

已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并按中序和后序的方式遍历该二叉树。

Input

连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

Output

每组输入数据对应输出2行:

第1行输出中序遍历序列;

第2行输出后序遍历序列。

Example Input

abc,,de,g,,f,,,

Example Output

cbegdfa

cgefdba

Hint

Author

xam

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
char a[55];//全局变量数组
int i;
struct node
{
char data;
struct node *lchild,*rchild;
};
struct node *creat()//按照先序输入构造树
{
char e;
struct node *t;
t = (struct node*)malloc(sizeof(struct node));
e = a[i++];
if(e==',')return NULL;
else
{
t -> data = e;
t -> lchild = creat();
t -> rchild = creat();
}
return t;
};
void zhongxu(struct node *t)//中序输出
{
if(t)
{
zhongxu(t->lchild);
printf("%c",t->data);
zhongxu(t->rchild);
}
}
void houxu(struct node *t)//后序输出
{
if(t)
{
houxu(t->lchild);
houxu(t->rchild);
printf("%c",t->data);
}
}
int main()
{
struct node *t;
while(~scanf("%s",a))
{
i = 0;
t = creat();
zhongxu(t);
printf("\n");
houxu(t);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息