您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之二叉树三:统计叶子数

2017-11-01 21:50 211 查看


数据结构实验之二叉树三:统计叶子数

Time Limit: 1000MS Memory Limit: 65536KB
[align=center]Submit Statistic[/align]

Problem Description

已知二叉树的一个按先序遍历输入的字符序列,如abc,,de,g,,f,,, (其中,表示空结点)。请建立二叉树并求二叉树的叶子结点个数。

Input

连续输入多组数据,每组数据输入一个长度小于50个字符的字符串。

Output

输出二叉树的叶子结点个数。

Example Input

abc,,de,g,,f,,,


Example Output

3

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
typedef struct node
{
char data;
struct node *l, *r;
}*bitree;
char s[55];
int cnt;
int t;
bitree create()
{
bitree root;
if(s[++cnt] == ',')
root = NULL;
else
{
root = new node;
root->data = s[cnt];
root->l = create();
root->r = create();
}
return root;
}
void zhongxu(bitree root)
{
if(root)
{
zhongxu(root->l);
if(root->l == NULL && root->r == NULL)
t++;
zhongxu(root->r);
}
}
int main()
{
while(~scanf("%s", s))
{
t = 0;
cnt = -1;
bitree root;
root = create();
zhongxu(root);
printf("%d", t);
printf("\n");
}
return 0 ;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: