您的位置:首页 > 理论基础 > 数据结构算法

SDUT-2804 数据结构实验之二叉树八:(中序后序)求二叉树的深度

2017-11-01 14:45 537 查看


数据结构实验之二叉树八:(中序后序)求二叉树的深度

Time Limit: 1000MS Memory Limit: 65536KB

Submit Statistic


Problem Description

已知一颗二叉树的中序遍历序列和后序遍历序列,求二叉树的深度。


Input

输入数据有多组,输入T,代表有T组数据。每组数据包括两个长度小于50的字符串,第一个字符串表示二叉树的中序遍历,第二个表示二叉树的后序遍历。


Output

输出二叉树的深度。


Example Input

2
dbgeafc
dgebfca
lnixu
linux



Example Output

4
3



Hint


Author

 
#include <iostream>
#include <string>
using namespace std;
struct Btree
{
Btree*left;
Btree*right;
char data;
};
string s1,s2;
Btree*build(string s1,string s2,int n)
{
int i;
if(n==0)
return NULL;
Btree*root;
root=new Btree;
root->data=s2[n-1];
for(i=0; i<n; i++)
{
if(s1[i]==root->data)
{
break;
}
}
root->left=build(s1,s2,i);
root->right=build(s1.substr(1+i),s2.substr(i),n-1-i);//ss=s.substr(start,(N));ss=s.substring(start,end);返回制定位置的字符串
return root;
}
int Depth(Btree*root)
{
if(root==NULL)
return 0;
else
{
int n1,n2;
n1=Depth(root->left);
n2=Depth(root->right);
return n1>n2?n1+1:n2+1;//利用n1+1和n2+1根据递归次数算出高度
}
}
int main()
{
int n,T;
while(cin>>T)
{
while(T--)
{
Btree*root;
cin>>s1;
cin>>s2;
n=s1.size();
root=build(s1,s2,n);
int d=Depth(root);
cout<<d<<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  树与二叉树
相关文章推荐