您的位置:首页 > 编程语言 > C语言/C++

PAT甲级 1029. Median (25)

2017-10-25 20:47 501 查看
题目:

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median
of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (<=1000000) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed
that all the integers are in the range of long int.

Output

For each test case you should output the median of the two given sequences in a line.
Sample Input
4 11 12 13 14
5 9 10 15 16 17

Sample Output
13

思路:
这道题一开始没想那么多,只是采用了向量vector的sort函数进行排序,但这会导致有一个测试点超时。根据题目中两个数列都是递增的信息,可以利用归并排序的方法查找中间值。

代码:

#include<iostream>
#include<vector>

using namespace std;
//归并排序
int main()
{
int i, j, num, k;
//input
long long m1, m2;
cin >> m1;
vector<long> n1(m1);
for (i = 0; i < m1; ++i)
cin >> n1[i];
cin >> m2;
vector<long> n2(m2);
for (i = 0; i < m2; ++i)
cin >> n2[i];

//calculate
long long i1, i2, i3, c1;
i1 = i2 = i3 = 0; //初始标
c1 = (m1 + m2) / 2 + (m1 + m2) % 2 - 1; //合并数组中间值的下标
bool flag = 1;
bool a = 1;
long tmp;
while (flag && a) //找到中间值或是两个数列都没有查找完
{
if (n1[i2] < n2[i3])
{

if (i1 == c1)
{
tmp = n1[i2];
flag = 0;
}
else
{
++i1;
++i2;
}
}
else
{
if (i1 == c1)
{
tmp = n2[i3];
flag = 0;
}
else
{
++i3;
++i1;
}
}

if (flag)
{
if ((i2 == m1) || (i3 == m2)) //判断是否越界
a = 0;
}

}
//针对还未查找到,但一个数组已用尽的情况
while (!a)
{
if (i2 < m1)
{
if (i1 == c1)
{
tmp = n1[i2];
a = 1;
}
else
{
++i1;
++i2;
}
}
else
{
if (i1 == c1)
{
tmp = n2[i3];
a = 1;
}
else
{
++i3;
++i1;
}
}
}
//output
cout << tmp << endl;

system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT c++