您的位置:首页 > 其它

HDU-5974-A Simple Math Problem

2017-10-14 17:17 302 查看

Problem Description

Given two positive integers a and b,find suitable X and Y to meet the conditions:

X+Y=a

Least Common Multiple (X, Y) =b

Input

Input includes multiple sets of test data.Each test data occupies one line,including two positive integers a(1≤a≤2*10^4),b(1≤b≤10^9),and their meanings are shown in the description.Contains most of the 12W test cases.

Output

For each set of input data,output a line of two integers,representing X, Y.If you cannot find such X and Y,output one line of “No Solution”(without quotation).

Sample Input

6 8

798 10780

Sample Output

No Solution

308 490

题意:

已知 a,b,找出一个x 和 y 满足 x+y=a,Lcm(x,y)=b;

思路(上网查找):

看数据范围肯定不能进行暴力枚举了!

令gcd(x,y) = g;

那么

g * k1 = x;

g * k2 = y;

因为g 是最大公约数,那么k1与k2 必互质!

=> g*k1*k2 = b

=> g*k1 + g * k2 = a;

所以k1 * k2 = b / g;

k1 + k2 = a/g;

因为k1与k2 互质!

所以k1 * k2 和 k1 + k2 也一定互质(一个新学的知识点= = )

所以a/g 与b/g也互质!

那么g 就是gcd(a,b);

所以我们得出一个结论: gcd(x,y) == gcd(a,b);;

所以x + y 与 x * y都是已知的了,解一元二次方程即可!

因为 gcd(a,b) * lcm(a,b) = a*b;

所以 lcm(a,b) = a/gcd(a,b)*b;

所以题目条件可化为一个一元二次方程:x*x-a*x+b*gcd(a,b)。

代码

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
using namespace std;
int a,b;
int gcd(int m,int n)
{
if(n == 0)
return m;
else
return gcd(n,m%n);
}
int main()
{
int m,p,l;
int q;
int x1,x2;
int flag;
while(scanf("%d%d",&a,&b)!=EOF)
{
flag = 1;
m = gcd(a,b);
p = a*a-4*b*m;  //解一元二次方程
if(p < 0)  //无解
{
printf("No Solution\n");
continue;
}
q = (int)sqrt(p);
if(q*q != p)//是否为整数
flag = 0;
x1 = (a+q)/2;

4000
x2 = (a-q)/2;
if(flag == 0)
printf("No Solution\n");
else
{
l = min(x1,x2);
printf("%d %d\n",l,a-l);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: