您的位置:首页 > 产品设计 > UI/UE

【HDU 5952 Counting Cliques】& DFS

2017-10-08 18:27 447 查看
Counting Cliques

Time Limit: 8000/4000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 2715 Accepted Submission(s): 982

Problem Description

A clique is a complete graph, in which there is an edge between every pair of the vertices. Given a graph with N vertices and M edges, your task is to count the number of cliques with a specific size S in the graph.

Input

The first line is the number of test cases. For each test case, the first line contains 3 integers N,M and S (N ≤ 100,M ≤ 1000,2 ≤ S ≤ 10), each of the following M lines contains 2 integers u and v (1 ≤ u < v ≤ N), which means there is an edge between vertices u and v. It is guaranteed that the maximum degree of the vertices is no larger than 20.

Output

For each test case, output the number of cliques with size S in the graph.

Sample Input

3

4 3 2

1 2

2 3

3 4

5 9 3

1 3

1 4

1 5

2 3

2 4

2 5

3 4

3 5

4 5

6 15 4

1 2

1 3

1 4

1 5

1 6

2 3

2 4

2 5

2 6

3 4

3 5

3 6

4 5

4 6

5 6

Sample Output

3

7

15

Source

2016ACM/ICPC亚洲区沈阳站-重现赛(感谢东北大学)

题意 : 给出的图中有多少含 S 个节点的完全图

思路 : DFS 搜一下,每加入一个点便判断这个点和其他点是否有边,保证加入的这个点后依然是完全图 ,为避免重复搜索没必要建双向边

AC代码:

#include<cstdio>
#include<cmath>
#include<deque>
#include<queue>
#include<vector>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX = 1e5 + 10;
const int INF = 1e9 + 7;
typedef long long LL;
int n,m,s,nl,head[MAX * 2],d[110][110];
int ans,u[110];
struct node{
int to,next;
}st[MAX * 2];
void add(int a,int b){
st[nl].to = b;
st[nl].next = head[a];
head[a] = nl++;
}
void dfs(int a,int b){
if(b == s){
ans++;
return ;
}
for(int i = head[a]; i != -1; i = st[i].next){
int o = st[i].to,ok = 1;
for(int j = 1; j <= b; j++)
if(!d[o][u[j]]){
ok = 0;
break;
}
if(ok){
u[b + 1] = o;
dfs(o,b + 1);
}
}
}
int main()
{
int T;
scanf("%d",&T);
while(T--){
nl = 0;
memset(head,-1,sizeof head);
scanf("%d %d %d",&n,&m,&s);
memset(d,0,sizeof d);
for(int i = 1; i <= m; i++){
int a,b;
scanf("%d %d",&a,&b);
d[a][b] = d[b][a] = 1;
add(a,b);
}
if(s == 2)
printf("%d\n",m);
else{
ans = 0;
for(int i = 1; i <= n; i++)
u[1] = i,dfs(i,1);
printf("%d\n",ans);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDU5952 DFS Counting