您的位置:首页 > 其它

POJ - 1014 - Dividing

2017-10-07 09:18 302 查看
Dividing

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 72353 Accepted: 18864
Description

Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in
half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the
same total value. Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot
be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
Input

Each line in the input file describes one collection of marbles to be divided. The lines contain six non-negative integers n1 , . . . , n6 , where ni is the number of marbles of value i. So, the example from above would be described by the input-line "1 0 1
2 0 0". The maximum total number of marbles will be 20000. 

The last line of the input file will be "0 0 0 0 0 0"; do not process this line.
4000

Output

For each collection, output "Collection #k:", where k is the number of the test case, and then either "Can be divided." or "Can't be divided.". 

Output a blank line after each test case.
Sample Input
1 0 1 2 0 0
1 0 0 0 1 1
0 0 0 0 0 0

Sample Output
Collection #1:
Can't be divided.

Collection #2:
Can be divided.

Source

Mid-Central European Regional Contest 1999

双重背包,数据压缩。。

#include <cstring>
#include <queue>
#include <cstdio>
#include <algorithm>
#include <string>
#include <map>
#include <set>
#include <vector>
#include <iostream>
#include <cmath>
using namespace std;
bool com[220000];
int main() {
int a[6],Case=0;
while(1) {
int MAX=0,flag=0,val[100];
memset(val,0,sizeof val);
for(int i=0; i<6; i++) {
scanf("%d",&a[i]);
MAX+=a[i]*(i+1);
for(int j=0;; j++) {
int t=(1<<j);
if(t>=a[i]) {
if(a[i]) val[flag++]=a[i]*(i+1);
break;
}
val[flag++]=t*(i+1);
a[i]-=t;
}
}
if(!MAX) break;
if(Case) cout<<endl;
if(MAX&1) {
printf("Collection #%d:\nCan't be divided.\n",++Case);
continue;
}
//sort(val,val+flag);
memset(com,false,sizeof com);
com[0]=true,MAX=MAX/2;
for(int i=0; i<flag; i++)
for(int j=MAX; j>=val[i]; j--)
if(j-val[i]>=0&&com[j-val[i]]) com[j]=true;
if(com[MAX])
printf("Collection #%d:\nCan be divided.\n",++Case);
else printf("Collection #%d:\nCan't be divided.\n",++Case);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: