您的位置:首页 > 其它

hdu 1069 Monkey and Banana

2017-09-22 12:30 239 查看

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 16545    Accepted Submission(s): 8805


[align=left]Problem Description[/align]
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough,
it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions
of the base and the other dimension was the height. 

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly
smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn't be stacked. 

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

 

[align=left]Input[/align]
The input file will contain one or more test cases. The first line of each test case contains an integer n,

representing the number of different blocks in the following data set. The maximum value for n is 30.

Each of the next n lines contains three integers representing the values xi, yi and zi.

Input is terminated by a value of zero (0) for n.

 

[align=left]Output[/align]
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".

 

[align=left]Sample Input[/align]

1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

 

[align=left]Sample Output[/align]

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

每种箱子根据摆放方式不同可以转换成六种长宽高不同的箱子,因为要搭楼,所以由下向上箱子底是递减的,翻过就是递增的;

#include <iostream>
#include <algorithm>
#include <string.h>

using namespace std;

struct node{
int x, y, z;
}block[220];
bool cmp(node a, node b){
if(a.x==b.x) return a.y < b.y;
else return a.x < b.x;
}
int main(){

int n;
int num=0;
while(cin >> n, n){
num++;
int cnt=0;
for(int i=1; i<=n; i++){
int xx, yy, zz;
cin >> xx >> yy >> zz;
block[++cnt].x=xx;
block[cnt].y=yy;
block[cnt].z=zz;

block[++cnt].x=xx;
block[cnt].y=zz;
block[cnt].z=yy;

block[++cnt].x=yy;
block[cnt].y=xx;
block[cnt].z=zz;

block[++cnt].x=yy;
block[cnt].y=zz;
block[cnt].z=xx;

block[++cnt].x=zz;
block[cnt].y=yy;
block[cnt].z=xx;

block[++cnt].x=zz;
block[cnt].y=xx;
block[cnt].z=yy;
}
sort(block+1, block+cnt+1, cmp);
for(int i=2; i<=cnt; i++){
int temp=0;
for(int j=1; j<i; j++){
if(((block[j].x<block[i].x && block[j].y<block[i].y) || (block[j].x<block[i].y && block[j].y<block[i].x)) && block[j].z>temp)
temp=block[j].z;
}
block[i].z+=temp;
}
int maxx=0;
for(int i=1; i<=cnt; i++){
maxx=max(maxx, block[i].z);
}
cout << "Case " << num << ": maximum height = " << maxx << endl;
}

return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: