您的位置:首页 > 理论基础 > 计算机网络

【POJ 1273 Drainage Ditches】 & 网络流 & Edmonds-Karp算法

2017-09-19 21:55 453 查看
Drainage Ditches

Time Limit: 1000MS Memory Limit: 10000K

Total Submissions: 78115 Accepted: 30465

Description

Every time it rains on Farmer John’s fields, a pond forms over Bessie’s favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie’s clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.

Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.

Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4

1 2 40

1 4 20

2 4 20

2 3 30

3 4 10

Sample Output

50

题意 : 1 到 m 的最大流

思路 :

1) 用bfs寻找一条源到汇的可行路径

2)寻找源到汇路径上容量最小的边,其容量就是此次增 加的总流量

3)沿此路径添加反向边,同时修改路径上每条边的容量

复杂度上限nm2 (n是 点数,m是边数)

AC代码:

#include<cstdio>
#include<cmath>
#include<queue>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAX = 3e2 + 10;
typedef long long LL;
int n,m,G[MAX][MAX];
int p[MAX]; //路径上每个节点的前驱节点
int vis[MAX];
int flow(){
int v;
memset(p,0,sizeof p);
memset(vis,0,sizeof vis);
p[1] = 0,vis[1] = 1;
deque <int> q; // 双向队列
q.push_back(1);
bool ok = false; //用bfs寻找一条源到汇的可行路径
while(!q.empty()){
v = q.front();
q.pop_front();
for(int i = 1; i <= m; i++){
if(G[v][i] && !vis[i]){
p[i] = v;
vis[i] = 1;
if(i == m){
ok = true;
q.clear();
break;
}
else
q.push_back(i);
}
}
}
if(!ok)
return 0;
int Minflow = 1e9 + 7;
v = m;
while(p[v]){ //寻找源到汇路径上容量最小的边,其容量就是此次增 加的总流量
Minflow = min(Minflow,G[p[v]][v]);
v = p[v];
}
v = m;
while(p[v]){ //沿此路径添加反向边,同时修改路径上每条边的容量
G[p[v]][v] -= Minflow;
G[v][p[v]] += Minflow;
v = p[v];
}
return Minflow;
}
int main()
{
while(~scanf("%d %d",&n,&m)){
int a,b,c;
memset(G,0,sizeof G);
for(int i = 1; i <= n; i++){
scanf("%d %d %d",&a,&b,&c);
G[a][b] += c; //两点之间可能有多条边
}
int Maxflow = 0;
int sum = 0;
while(sum = flow())
Maxflow += sum;
printf("%d\n",Maxflow);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息