您的位置:首页 > 其它

LightOJ-1370 Bi-shoe and Phi-shoe

2017-09-11 08:33 330 查看

题目:

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all
possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo's length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than nwhich are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is
6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number.
Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input
Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky
number will lie in the range [1, 106].

Output
For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input
3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output
Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha

题意:

给出n的数字,每个数找到欧拉函数值大于等于的这个数的数,求这n个数的最小和

分析:

欧拉函数:欧拉函数是求小于等于n的数中与n互质的数的数目
参考欧拉函数
先打表求出欧拉函数的值,再根据欧拉函数的值在打表求出每个数欧拉函数值大于等于的自己的第一个数。

代码:

#include<stdio.h>
const int N = 3e6+3e5 ;
int phi
, prime
,ans[1000005];
int tot;//tot计数,表示prime
中有多少质数
void Euler(){
phi[1] = 0;
for(int i = 2; i < N; i ++){
if(!phi[i]){
phi[i] = i-1;
prime[tot ++] = i;
}
for(int j = 0; j < tot && 1ll*i*prime[j] < N; j ++){
if(i % prime[j]) phi[i * prime[j]] = phi[i] * (prime[j]-1);
else{
phi[i * prime[j] ] = phi[i] * prime[j];
break;
}
}
}
}
void init(){
int pos=1;
for(int i=1;i<=1e6;i++){
while(phi[pos]<i) pos++;
ans[i]=pos;
}
}
int main(){
int t;
scanf("%d",&t);
int cas=0;
Euler();
init();
while(t--){
cas++;
int n;
scanf("%d",&n);
long long Ans=0;
for(int i=0;i<n;i++){
int num;
scanf("%d",&num);
Ans+=(long long)ans[num];
}
printf("Case %d: %lld Xukha\n",cas,Ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: