您的位置:首页 > 其它

hdu 4763 kmp的简单应用

2017-09-08 20:12 316 查看

Theme Section

Problem Description

It’s time for music! A lot of popular musicians are invited to join us in the music festival. Each of them will play one of their representative songs. To make the programs more interesting and challenging, the hosts are going to add some constraints to the rhythm of the songs, i.e., each song is required to have a ‘theme section’. The theme section shall be played at the beginning, the middle, and the end of each song. More specifically, given a theme section E, the song will be in the format of ‘EAEBE’, where section A and section B could have arbitrary number of notes. Note that there are 26 types of notes, denoted by lower case letters ‘a’ - ‘z’.

To get well prepared for the festival, the hosts want to know the maximum possible length of the theme section of each song. Can you help us?

Input

The integer N in the first line denotes the total number of songs in the festival. Each of the following N lines consists of one string, indicating the notes of the i-th (1 <= i <= N) song. The length of the string will not exceed 10^6.

Output

There will be N lines in the output, where the i-th line denotes the maximum possible length of the theme section of the i-th song.

Sample Input

5

xy

abc

aaa

aaaaba

aaxoaaaaa

Sample Output

0

0

1

1

2

Source

2013 ACM/ICPC Asia Regional Changchun Online

解题思路:给出一个字符串,求出公共前后缀,然后在去掉公共前后缀之后,必须在剩下的串中找到这个缀才满足题目中的要求。由此可知,长度小于3的串都找不到这样的前后缀,等于3的时候必须三个字符都相同才行。其他的都作一般情况讨论,先找到最长公共前后缀,然后KMP处理看是否能在剩下的串中找到这个缀,找到则直接输出这个缀的长度,找不到的话就返回这个缀的最大公共前后缀的长度。

#include <stdio.h>
#include <string.h>
#define N 1000005
int next
,sum;
char p
;

void get_next(char p[])
{
int j=0;
int k=-1,s;
int l=strlen(p);
next[0]=-1;
while(j<l)
{
if(k==-1||p[j]==p[k])
{
k++;
j++;
next[j]=k;
}
else
k=next[k];
}
if(l==3){
if(p[0]==p[1]&&p[1]==p[2])
sum=1;
else
sum=0;
}
else if(next[l]!=0&&l>3){
int f=l;
int flag=0;
int i,j;
while(f<=l&&f>0)
{
if(next[f]*3>l){
f=next[f];
continue;
}
i=0;j=f;s=0;
while(i<f&&j<l-f&&j>=f)
{
if(p[i]==p[j]||i==0)
{
i++;
j++;
s++;
}
else
i=next[i];
if(s==f)
{
flag=1;
break;
}
}
if(flag==1){
sum=f;
break;
}
else
f=next[f];
}
}
}

int main()
{
int t;
scanf("%d",&t);
while(t--)
{
sum=0;
scanf("%s",p);
get_next(p);
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: