您的位置:首页 > 其它

HDU5831-Rikka with Parenthesis II

2017-09-07 14:47 309 查看


Rikka with Parenthesis II

                                                                Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536
K (Java/Others)

                                                                                        Total Submission(s): 1740    Accepted Submission(s): 758


Problem Description

As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Correct parentheses sequences can be defined recursively as follows:

1.The empty string "" is a correct sequence.

2.If "X" and "Y" are correct sequences, then "XY" (the concatenation of X and Y) is a correct sequence.

3.If "X" is a correct sequence, then "(X)" is a correct sequence.

Each correct parentheses sequence can be derived using the above rules.

Examples of correct parentheses sequences include "", "()", "()()()", "(()())", and "(((())))".

Now Yuta has a parentheses sequence S,
and he wants Rikka to choose two different position i,j and
swap Si,Sj. 

Rikka likes correct parentheses sequence. So she wants to know if she can change S to a correct parentheses sequence after this operation.

It is too difficult for Rikka. Can you help her?

 

Input

The first line contains a number t(1<=t<=1000), the number of the testcases. And there are no more then 10 testcases with n>100

For each testcase, the first line contains an integers n(1<=n<=100000), the length of S. And the second line contains a string of length S which only contains ‘(’ and ‘)’.

 

Output

For each testcase, print "Yes" or "No" in a line.

 

Sample Input

3
4
())(
4
()()
6
)))(((

 

Sample Output

Yes
Yes
No

Hint
For the second sample input, Rikka can choose (1,3) or (2,4) to swap. But do nothing is not allowed.

 

Author

学军中学

 

Source

2016 Multi-University Training Contest 8

 

Recommend

wange2014

 

题意:给你一个只包含左括号或右括号的串,交换其中两个括号的位置一次,使得串变成合法的

解题思路:若符号为‘(’则加一,否则减一,若第一次和标记为零且碰到符号为‘)’,那么将这个符号变为‘(’并加一,若第二次出现这种情况,那么必然不可能变为合法串

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <map>
#include <cmath>
#include <set>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <functional>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

int n;
char ch[100009];

int main()
{
int t;
scanf("%d", &t);
while (t--)
{
scanf("%d%s", &n, ch);
int sum1 = 0, sum2 = 0;
for (int i = 0; ch[i]; i++)
{
if (ch[i] == '(') sum1++;
else sum2++;
}
if (sum1 != sum2) { printf("No\n"); continue; }
if (n == 2 && !strcmp(ch, "()")) { printf("No\n"); continue; }
int flag1 = 0, flag2 = 0, sum = 0;
for (int i = 0; i<n; i++)
{
if (ch[i] == '(') sum++;
else
{
if (sum) { sum--; continue; }
if (flag1 == 0) flag1 = 1, sum++;
else { flag2 = 1; break; }
}
}
if (flag2 != 1) printf("Yes\n");
else printf("No\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: