您的位置:首页 > 其它

hdu 1219 hash

2017-09-06 08:00 267 查看
Problem Description

Ignatius is doing his homework now. The teacher gives him some articles and asks him to tell how many times each letter appears.

It’s really easy, isn’t it? So come on and AC ME.

Input

Each article consists of just one line, and all the letters are in lowercase. You just have to count the number of each letter, so do not pay attention to other characters. The length of article is at most 100000. Process to the end of file.

Note: the problem has multi-cases, and you may use “while(gets(buf)){…}” to process to the end of file.

Output

For each article, you have to tell how many times each letter appears. The output format is like “X:N”.

Output a blank line after each test case. More details in sample output.

Sample Input

hello, this is my first acm contest!

work hard for hdu acm.

Sample Output

a:1

b:0

c:2

d:0

e:2

f:1

g:0

h:2

i:3

j:0

k:0

l:2

m:2

n:1

o:2

p:0

q:0

r:1

s:4

t:4

u:0

v:0

w:0

x:0

y:1

z:0

a:2

b:0

c:1

d:2

e:0

f:1

g:0

h:2

i:0

j:0

k:1

l:0

m:1

n:0

o:2

p:0

q:0

r:3

s:0

t:0

u:1

v:0

w:1

x:0

y:0

z:0

题解:

哈希记录一下即可。一开始把计数数组设置成char wa了。粗心了。

代码:

#include <bits/stdc++.h>

using namespace std;
const int maxn = 100000+100;
char str[maxn];
int num[26];

int main()
{
while(gets(str)!=NULL)
{
memset(num,0,sizeof(num));
int len = strlen(str);
for(int i=0;i<len;i++)
{
//cout<<str[i]<<" ";
if(isalpha(str[i]))
num[str[i]-'a']++;
}
for(int i=0;i<26;i++)
{
printf("%c:%d\n",i+'a',num[i]);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: