您的位置:首页 > 其它

POJ2229 Sumsets

2017-09-05 07:53 204 查看

Description

Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1

2) 1+1+1+1+1+2

3) 1+1+1+2+2

4) 1+1+1+4

5) 1+2+2+2

6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).

Input

A single line with a single integer, N.

Output

The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).

Sample Input

7

Sample Output

6

找规律做出

多写几组数据:

1 -> 1

2 -> 2

3 -> 2

4 -> 4

5 -> 4

6 -> 6

7 -> 6

就可以看出来当n为奇数,ans=sum[n-1],n为偶数时,ans=sum[n-1]+sum[n/2]

CODE

#include <stdio.h>
int sum[1000000];
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{

sum[1]=1;
sum[2]=2;
for(int i=3;i<=n;i++)
{
if(i%2!=0)
sum[i]=sum[i-1];
else
sum[i]=(sum[i-2]+sum[i/2])%1000000000;
}
printf("%d\n",sum
);
}
}


看了题解后,这不是规律,这是有道理的!而且这题是可以用动态规划做的!

所谓找规律的道理所在:

设a
为和为 n 的种类数;

根据题目可知,加数为2的N次方,即 n 为奇数时等于它前一个数 n-1 的种类数 a[n-1] ,若 n 为偶数时分加数中有无 1 讨论,即关键是对 n 为偶数时进行讨论:

1.n为奇数,a
=a[n-1]

2.n为偶数:

(1)如果加数里含1,则一定至少有两个1,即对n-2的每一个加数式后面 +1+1,总类数为a[n-2];

(2)如果加数里没有1,即对n/2的每一个加数式乘以2,总类数为a[n/2];

所以总的种类数为:a
=a[n-2]+a[n/2];

动态规划思想:

附一个完全背包解法,暂时没有想出这个代码的含义

#include <iostream>
#include <cstdio>
#include <string.h>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <math.h>
#include <algorithm>
using namespace std;
#define LL long long
#define INF 0x3f3f3f3f
const double pi = acos(-1.0);
const int mod = 1e9;

const int N =1e6+10;

int dp
;

void Init()
{
memset(dp,0,sizeof(dp));

dp[0]=dp[1]=1;
for(int i=1;i<=22;i++)
{
for(int j=2;j<=1000000;j++)
{
int v=1<<(i-1);
if(j>=v)
dp[j]=dp[j-v]+dp[j];
while(dp[j]>mod)
dp[j]-=mod;
}
}
}
int main()
{
int n;
Init();
while(~scanf("%d",&n))
printf("%d\n",dp
);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj