您的位置:首页 > 其它

算法提高 ADV-105 不同单词个数统计

2017-08-25 00:26 253 查看
问题描述

  编写一个程序,输入一个句子,然后统计出这个句子当中不同的单词个数。例如:对于句子“one little two little three little boys”,总共有5个不同的单词:one, little, two, three, boys。

  说明:(1)由于句子当中包含有空格,所以应该用gets函数来输入这个句子;(2)输入的句子当中只包含英文字符和空格,单词之间用一个空格隔开;(3)不用考虑单词的大小写,假设输入的都是小写字符;(4)句子长度不超过100个字符。

  输入格式:输入只有一行,即一个英文句子。

  输出格式:输出只有一行,是一个整数,表示句子中不同单词的个数。
输入输出样例

样例输入

one little two little three little boys

样例输出

    5

import java.io.BufferedReader;
imp
4000
ort java.io.IOException;
import java.io.InputStreamReader;
import java.util.HashSet;
import java.util.Set;
import java.util.StringTokenizer;

public class Main{
public static void main(String[] args) throws IOException {
BufferedReader bfr = new BufferedReader(
new InputStreamReader(System.in));
String str = bfr.readLine();
if (!str.contains(" ")){
System.out.println("1");
return;
}
StringTokenizer st = new StringTokenizer(str, " ", true);
Set<String> set = new HashSet<String>();
while (st.hasMoreElements()) {
set.add(st.nextToken());
}

System.out.println(set.size()-1);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: