您的位置:首页 > 其它

[POJ](1936)All in All ---字符串匹配(串)

2017-08-22 19:43 1051 查看
All in All

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 33567 Accepted: 14013
Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into
the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string. 

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s. 

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.
Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".
Sample Input
sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output
Yes
No
Yes
No


解题新知:题意就是给你两个串s和t,问你s是不是t的子序列~可以直接暴力模拟,题比较水

AC代码:
#include<stdio.h>
#include<string.h>
int main()
{
int flag;
long long int i,j,l1,l2,count,count1;
char s[100002];
char t[1000
ad0d
02];
while(scanf("%s %s",s,t)!=EOF)
{
count=0;
count1=0;
i=0,j=0;
flag=1;
l1=strlen(t);
while(1)
{
if(t[i]!=s[j])
i++;
else if(t[i]==s[j])
{
i++;
j++;
count++;
}
if(count==strlen(s))
{
printf("Yes\n");
break;
}
else
count1++;
if(count1==l1)
{
printf("No\n");
break;
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: