您的位置:首页 > 其它

poj 3734 Blocks【矩阵快速幂染色】

2017-08-21 16:21 399 查看
Description

Panda has received an assignment of painting a line of blocks. Since Panda is such an intelligent boy, he starts to think of a math problem of painting. Suppose there are N blocks in a line and each block can be paint red, blue, green or yellow. For some myterious reasons, Panda want both the number of red blocks and green blocks to be even numbers. Under such conditions, Panda wants to know the number of different ways to paint these blocks.

Input

The first line of the input contains an integer T(1≤T≤100), the number of test cases. Each of the next T lines contains an integer N(1≤N≤10^9) indicating the number of blocks.

Output

For each test cases, output the number of ways to paint the blocks in a single line. Since the answer may be quite large, you have to module it by 10007.

Sample Input

2

1

2

Sample Output

2

6

思路:

a[i]:表示前i个红绿都是偶数的方案

b[i]:表示前i个红绿其中有一个是偶数的方案

c[i]:表示前i个红绿都不是偶数的方案

a[i + 1] = 2 * a[i] + b[i] ;

b[i + 1] = 2 * a[i] + 2 * b[i] + 2 * c[i] ;

c[i + 1] = b[i] + 2 * c[i] ;

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
const int mod = 10007;

struct mat {
int mapp[3][3];
}base, ans;

mat mat_mul(mat A, mat B) {
mat C;
memset(C.mapp, 0, sizeof(C.mapp));
for(int i = 0; i < 3; i++) {
for(int j = 0; j < 3; j++) {
for(int k = 0; k < 3; k++) {
C.mapp[i][k] = (C.mapp[i][k] + A.mapp[i][j] * B.mapp[j][k] % mod) % mod;
}
}
}
return C;
}

int quick_pow(mat A, int b) {
memset(ans.mapp, 0, sizeof(ans.mapp));
for(int i = 0; i < 3; i++) {
ans.mapp[i][i] = 1; //初始矩阵
}
while(b) {
if(b & 1) ans = mat_mul(ans, A);
A = mat_mul(A, A);
b >>= 1;
}
return ans.mapp[0][0];
}

int main() {
int t, n;
scanf("%d", &t);
while(t--) {
base.mapp[0][0] = 2; //推导矩阵
base.mapp[0][1] = 1;
base.mapp[0][2] = 0;
base.mapp[1][1] = 2;
base.mapp[1][2] = 2;
base.mapp[2][1] = 1;
base.mapp[2][2] = 2;
scanf("%d", &n);
printf("%d\n", quick_pow(base, n) % mod);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: