您的位置:首页 > 其它

HDOJ 1325 Is It A Tree? (并查集的查找)

2017-08-20 13:04 274 查看

Is It A Tree?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1246 Accepted Submission(s): 392
 
Problem Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 

There is exactly one node, called the root, to which no directed edges point. 

Every node except the root has exactly one edge pointing to it. 

There is a unique sequence of directed edges from the root to each node. 

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.







In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.
 
Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers;
the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
 
Output

            For each test case display the line ``Case k is a tree.\\\\\\\" or the line ``Case k is not a tree.\\\\\\\", where k corresponds to the test case number (they are sequentially numbered starting with 1).
 
Sample Input

6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1


 
Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.


 
 
Source

North Central North America 1997
 
Recommend

Ignatius.L
 
题意:1.一个结点不能有两个父亲  2.只能是一棵树,不能是两棵

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
#define N 1000000//不知道范围 所以开10的6次方

int father
;
int a
;//存放所有子节点
void init()
{
for (int i = 0; i < N; i++)
{
father[i] = i;
}
}

int find(int x)//不能压缩路径
{
if (father[x] == x)return x;
return find(father[x]);
}

int main()
{
int n, m;
int cnt=0;
while (scanf("%d%d",&n,&m)!=EOF)
{
int k = 0;
init();
cnt++;
bool flag = true;
if (n < 0 && m < 0)break;
father[m] = n;
a[k++] = m;
while (1)
{
scanf("%d%d", &n, &m);
if (n == 0 && m == 0)break;
if (!flag)continue;
if (father[m] != m&&father[m] != n) { flag = false; continue; }//是否两个父亲节点
father[m] = n;
a[k++] = m;
}
int temp = find(a[0]);
for (int i = 1; i < k; i++)//如果是一棵树 所有结点的头节点都是同一个
{
if (temp != find(a[i])) { flag = false; break; }
}
printf("Case %d is ", cnt);
if (flag)printf("a tree.\n");
else printf("not a tree.\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: