您的位置:首页 > 编程语言 > C语言/C++

[PAT甲级]1001. A+B Format (20)(AB和的标准输出)

2017-08-16 18:08 429 查看

1001. A+B Format (20)

原题链接

Calculate a + b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9


Sample Output

-999,991


题目大意:

输入两个数a,b,输出它们的和

最后的输出按照标准输出,从右往左每3个数字加一个逗号

代码:

#include <iostream>
#include <string>
using namespace std;

int main()
{
int a,b;
cin >> a >> b;
int sum = a + b;
string res="";
bool flag = true;//正数
if(sum < 0){
flag = false;
sum = -sum;
}
int t=0;
do{
if(t == 3){
res = ',' + res;
t = 0;
}
char c = sum%10+'0';
res = c + res;
t++;
sum /= 10;
}while(sum != 0);
if(!flag)
res = '-' + res;
cout << res;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息