您的位置:首页 > 其它

hdu6106Classes(交集计算集合)

2017-08-15 10:32 169 查看


Classes

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 668    Accepted Submission(s): 425


Problem Description

The school set up three elective courses, assuming that these courses are A, B, C. N classes of students enrolled in these courses.

Now the school wants to count the number of students who enrolled in at least one course in each class and records the maximum number of students.

Each class uploaded 7 data, the number of students enrolled in course A in the class, the number of students enrolled in course B, the number of students enrolled in course C, the number of students enrolled in course AB, the number of students enrolled in
course BC, the number of students enrolled in course AC, the number of students enrolled in course ABC. The school can calculate the number of students in this class based on these 7 data.

However, due to statistical errors, some data are wrong and these data should be ignored.

Smart you must know how to write a program to find the maximum number of students.

 

Input

The first line of the input gives the number of test cases T; T test cases follow.

Each case begins with one line with one integer N, indicates the number of class.

Then N lines follow, each line contains 7 data: a, b, c, d, e, f, g, indicates the number of students enrolled in A, B, C, AB, BC, AC, ABC in this class. 

It's guaranteed that at least one data is right in each test case.

Limits
T≤100
1≤N≤100
0≤a,b,c,d,e,f,g≤100

 

Output

For each test case output one line contains one integer denotes the max number of students who enrolled in at least one course among N classes.

 

Sample Input

2
2
4 5 4 4 3 2 2
5 3 1 2 0 0 0
2
0 4 10 2 3 4 9
6 12 6 3 5 3 2

 

Sample Output

7
15

Hint
In the second test case, the data uploaded by Class 1 is wrong.
Because we can't find a solution which satisfies the limitation.
As for Class 2, we can calculate the number of students who only enrolled in course A is 2,
the number of students who only enrolled in course B is 6, and nobody enrolled in course C,
the number of students who only enrolled in courses A and B is 1,
the number of students who only enrolled in courses B and C is 3,
the number of students who only enrolled in courses A and C is 1,
the number of students who enrolled in all courses is 2,
so the total number in Class 2 is 2 + 6 + 0 + 1 + 3 + 1 + 2 = 15.

 

Source

2017 Multi-University Training Contest - Team 6

给a,b,c,ab,ac,bc,abc七种选择的学生,要你计算出总人数,由于选abc的肯定选了ac,bc,ab,所以后者先减去abc的人数,这样剩下的就是只选ab,ac,bc,的了,然后由于选了ab,ac,bc,的肯定选了a,b,c,再用a,b,c,分别减去ab,ac,bc,abc的,留下的人都是直选自己内部的了,然后统计人数就行啦~

注意判断错误案例

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>
#include <iostream>
using namespace std;
#define mod 1000000007
#define LL long long
int main()
{
int t;
int n;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
int a,b,c,ab,bc,ac,abc;
int max=0;
while(n--)
{
scanf("%d %d %d %d %d %d %d",&a,&b,&c,&ab,&bc,&ac,&abc);
int sum;
ac-=abc;
bc-=abc;
ab-=abc;
a-=abc;
a-=ab;
a-=ac;
b-=ab;
b-=abc;
b-=bc;
c-=ac;
c-=bc;
c-=abc;
if(a<0||b<0||c<0||ab<0||bc<0||ac<0||abc<0)
{sum=0;continue;}
else sum=a+b+c+ab+ac+bc+abc;
if(sum>max)
max=sum;
}
cout<<max<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: