您的位置:首页 > 其它

Prime Gap (素数)

2017-08-11 21:36 302 查看
[align=left]Problem Description[/align]

The sequence of n 1 consecutive composite numbers (positive integers that are not prime and not equal to 1) lying between two successive prime numbers
p and p + n is called a prime gap of length n. For example, 24, 25, 26, 27, 28 between 23 and 29 is a prime gap of length 6.

Your mission is to write a program to calculate, for a given positive integer
k, the length of the prime gap that contains k. For convenience, the length is considered 0 in case no prime gap contains
k.

[align=left]Input[/align]
<p>The input is a sequence of lines each of which contains a single positive integer. Each positive integer is greater than 1 and less than or equal to the 100000th prime number, which is 1299709. The end of the input is indicated
by a line containing a single zero.</p>

[align=left]Output[/align]
<p>The output should be composed of lines each of which contains a single non-negative integer. It is the length of the prime gap that contains the corresponding positive integer in the input if it is a composite number, or 0 otherwise.
No other characters should occur in the output.</p>

[align=left]Sample Input[/align]

10
11
27
2
492170
0

[align=left]Sample Output[/align]

4
0
6
0
114

题目大概:

求素数间隙,主要是要把素数打表。

思路:

晒素数。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int n;
int su[1300000];

int sushu()
{ su[0]=su[1]=1;
for(int i=2;i<=1300000;i++)
{
if(su[i]==0)
{
for(int j=i+i;j<=1300000;j=j+i)
{
su[j]=1;
}
}
}

}
int main()
{ memset(su,0,sizeof(su));
sushu();

while(scanf("%d",&n)&&n)
{
if(!su
)
{
printf("0\n");
}
else
{
int x=n-1;
int y=n+1;
while(su[x])x--;
while(su[y])y++;
printf("%d\n",y-x);
}

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数论 素数