您的位置:首页 > 产品设计 > UI/UE

【PAT】【Advanced Level】1062. Talent and Virtue (25)

2017-08-10 20:14 405 查看


1062. Talent and Virtue (25)

时间限制

200 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Li

About 900 years ago, a Chinese philosopher Sima Guang wrote a history book in which he talked about people's talent and virtue. According to his theory, a man being outstanding in both talent and virtue must be a "sage(圣人)"; being less excellent but with one's
virtue outweighs talent can be called a "nobleman(君子)"; being good in neither is a "fool man(愚人)"; yet a fool man is better than a "small man(小人)" who prefers talent than virtue.

Now given the grades of talent and virtue of a group of people, you are supposed to rank them according to Sima Guang's theory.

Input Specification:

Each input file contains one test case. Each case first gives 3 positive integers in a line: N (<=105), the total number of people to be ranked; L (>=60), the lower bound of the qualified grades -- that is, only the ones whose
grades of talent and virtue are both not below this line will be ranked; and H (<100), the higher line of qualification -- that is, those with both grades not below this line are considered as the "sages", and will be ranked in non-increasing order according
to their total grades. Those with talent grades below H but virtue grades not are cosidered as the "noblemen", and are also ranked in non-increasing order according to their total grades, but they are listed after the "sages". Those with both grades below
H, but with virtue not lower than talent are considered as the "fool men". They are ranked in the same way but after the "noblemen". The rest of people whose grades both pass the L line are ranked after the "fool men".

Then N lines follow, each gives the information of a person in the format:
ID_Number Virtue_Grade Talent_Grade

where ID_Number is an 8-digit number, and both grades are integers in [0, 100]. All the numbers are separated by a space.

Output Specification:

The first line of output must give M (<=N), the total number of people that are actually ranked. Then M lines follow, each gives the information of a person in the same format as the input, according to the ranking rules. If there is a tie of the total grade,
they must be ranked with respect to their virtue grades in non-increasing order. If there is still a tie, then output in increasing order of their ID's.
Sample Input:
14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60

Sample Output:
12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90


原题链接:

https://www.patest.cn/contests/pat-a-practise/1062

https://www.nowcoder.com/pat/5/problem/4029

思路:

条件判断+结构体排序

CODE:

#include<iostream>
#include<vector>
#include<string>
#include<cstring>
#include<algorithm>
#include<cstdio>
using namespace std;
typedef struct S
{
int sno;
int d;
int c;
};
//坑点:输入、输出采用scanf 和printf,否则TLE
S s[4][100000];
int n[4]={0,0,0,0};

bool cmp(S a, S b)
{
return a.d+a.c==b.d+b.c?(a.d==b.d?a.sno<b.sno:a.d>b.d):a.d+a.c>b.d+b.c;

}
int main()
{
int a,p,q;
scanf("%d %d %d",&a,&p,&q);
int bjg=0;
for (int i=0;i<a;i++)
{
S t;
//t.sno.resize(100);
scanf("%d %d %d",&t.sno,&t.d,&t.c);
//cin>>t.sno>>t.d>>t.c;
//cout<<t.sno<<t.d<<t.c<<endl;
if (t.d>=q && t.c>=q)
s[0][n[0]++]=t;
else if(t.d>=q&&t.c>=p)
s[1][n[1]++]=t;
else if(t.d>=t.c&&t.d>=p&&t.c>=p)
s[2][n[2]++]=t;
else if(t.d>=p&&t.c>=p)
s[3][n[3]++]=t;
else
{
bjg++;
}
}
for (int i=0;i<4;i++)
sort(s[i],s[i]+n[i],cmp);
//cout<<a-bjg<<endl;
printf("%d\n",a-bjg);
for (int i=0;i<4;i++)
{
for (int j=0;j<n[i];j++)
{
printf("%d %d %d",s[i][j].sno,s[i][j].d,s[i][j].c);
//cout<<s[i][j].sno<<" "<<s[i][j].d<<" "<<s[i][j].c;
if(!(i==3 && j==n[3])) printf("\n");
}
}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: