您的位置:首页 > 其它

HDU 6095 Rikka with Competition【阅读题】【水题】

2017-08-10 10:24 489 查看


Rikka with Competition

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 444    Accepted Submission(s): 365


Problem Description

As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

A wrestlin
4000
g match will be held tomorrow. n players
will take part in it. The ith
player’s strength point is ai.

If there is a match between the ith
player plays and the jth
player, the result will be related to |ai−aj|.
If |ai−aj|>K,
the player with the higher strength point will win. Otherwise each player will have a chance to win.

The competition rules is a little strange. Each time, the referee will choose two players from all remaining players randomly and hold a match between them. The loser will be be eliminated. After n−1 matches,
the last player will be the winner.

Now, Yuta shows the numbers n,K and
the array a and
he wants to know how many players have a chance to win the competition.

It is too difficult for Rikka. Can you help her?  

 

Input

The first line contains a number t(1≤t≤100),
the number of the testcases. And there are no more than 2 testcases
with n>1000.

For each testcase, the first line contains two numbers n,K(1≤n≤105,0≤K<109).

The second line contains n numbers ai(1≤ai≤109).

 

Output

For each testcase, print a single line with a single number -- the answer.

 

Sample Input

2
5 3
1 5 9 6 3
5 2
1 5 9 6 3

 

Sample Output

5
1

 

Source

2017 Multi-University Training Contest - Team 5

题意:

给你一组n个数,代表n个选手的能量高低,现在再给你一个k,任意在n个选手中挑取两个选手比赛,如果 |ai−aj|>K那么能量高的选手获胜,另一个将被淘汰,否则两个人都有机会获胜,现在要你求有多少人有获胜的可能。

思路:

第i个人要获胜那么最好的情况是比他强的人和次强的人比,次强的人赢,然后次的人再和次次强的人比,次次强的人赢,以此类推,这样这个人赢的可能性才最大。所以把ai按大小顺序进行排序,让最强的与次强的比,如果相差小于k则ans++否则直接跳出,此时ans则为最优结果。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <string>
#include <map>
#include <cstring>
#define INF 0x3f3f3f3f
#define ms(x,y) memset(x,y,sizeof(x))
using namespace std;

typedef long long ll;
typedef unsigned long long ull;
typedef pair<int, int> P;

const int maxn = 100050;
const int mod = 998244353;

#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1

int a[maxn] = { 0 };

int main()
{
int t;
scanf("%d", &t);
while (t--)
{
int n, k;
scanf("%d%d", &n, &k);
for (int i = 0; i < n; i++)
{
scanf("%d", &a[i]);
}
sort(a, a + n);
int ans = 1;
for (int i = n - 1; i >= 1; i--)
{
if (a[i] - a[i - 1] > k)
{
break;
}
ans++;
}
printf("%d\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: