您的位置:首页 > 其它

hdu 6090-Rikka with Graph

2017-08-10 08:51 369 查看
Rikka with Graph

Problem Description 

As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

For an undirected graph G with n nodes and m edges, we can define the distance between (i,j) (dist(i,j)) as the length of the shortest path between i and j. The length of a path is equal to the number of the edges on it. Specially, if there are no path between
i and j, we make dist(i,j) equal to n.

Then, we can define the weight of the graph G (wG) as ∑ni=1∑nj=1dist(i,j).

Now, Yuta has n nodes, and he wants to choose no more than m pairs of nodes (i,j)(i≠j) and then link edges between each pair. In this way, he can get an undirected graph G with n nodes and no more than m edges.

Yuta wants to know the minimal value of wG.

It is too difficult for Rikka. Can you help her?

In the sample, Yuta can choose (1,2),(1,4),(2,4),(2,3),(3,4).

Input 

The first line contains a number t(1≤t≤10), the number of the testcases.

For each testcase, the first line contains two numbers n,m(1≤n≤106,1≤m≤1012).

Output 

For each testcase, print a single line with a single number – the answer.

Sample Input 



4 5

Sample Output 

14
每次都做签到题都想写了,哎,太菜;
code
#include<bits/stdc++.h>

using namespace std;

int main()
{
int t;
cin >> t;
while (t--)
{
long long n, m;
cin >> n >> m;
if (n * (n - 1) / 2 <= m) //每两个都相连的临界
{
cout << n * (n - 1) << endl;
continue;
}
long long ans = n * (n - 1);
if (m >= (n - 1))    // 漏边,但不漏点
{
ans += 2 * (n * (n - 1) / 2 - m);
}
else   //漏点
{
ans =2*m*m+(m*n+n*n)*(n-1-m);
}

cout << ans << endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: