您的位置:首页 > 其它

Truck History (Prim算法)

2017-08-09 17:11 183 查看

Truck History

Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 79   Accepted Submission(s) : 27
[align=left]Problem Description[/align]
Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string
of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from
the new types another types were derived, and so on.

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different
letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as

1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types.

Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

 

[align=left]Input[/align]
The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase
letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

 

[align=left]Output[/align]
For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

 

[align=left]Sample Input[/align]

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

 

[align=left]Sample Output[/align]

The highest possible quality is 1/3.

 

[align=left]Source[/align]
PKU

题意:

给出n个长度为7的字符串,每个字符串代表一个车,定义车的距离是两个字符串间不同字母的个数,题目要求的数不同的车的距离的最小值,即所求的就是最小生成树

思路:

用prim算法,一开始套的模板结果超市,后来修改了一点,Ac了。。。。

代码:

#include <iostream>
#include <cstring>
#include <string>
#include <stdio.h>
#define inf 0x3f3f3f3f
using namespace std;
int g[3000][3000];
int minn[3000];
bool u[3000];
string ss[3000];
int main()
{
//ios::sync_with_stdio(false);
int n,i,j;
while(scanf("%d",&n),n){
for(i=1;i<=n;i++)
{
cin>>ss[i];
for(j=1;j<=i;j++)
{
if(i==j){g[i][j]=0;continue;}
int tt=0;
for(int k=0;k<7;k++){if(ss[i][k]!=ss[j][k])tt++;}//记录距离
g[i][j]=g[j][i]=tt;
}
}
memset(minn,0x7f,sizeof(minn));
minn[1]=0;
memset(u,1,sizeof(u));
//int sum=0;
int cnt=inf;
for(i=1;i<=n;i++)
{
int k=0;
for(j=1;j<=n;j++)//找一个与生成树点相连的不在生成树的最小的点
if(u[j]&&(minn[j]<minn[k]))k=j;
u[k]=0; //k入树

for(j=1;j<=n;j++) //修改所有与k相连的未进入生成树的点
if(u[j]&&(g[k][j]<minn[j]))
minn[j]=g[k][j];
}
int sum=0;
for(i=1;i<=n;i++)sum+=minn[i]; //累加权值
printf("The highest possible quality is 1/%d.\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: