您的位置:首页 > 其它

UVA 100 - The 3n+1 Problem

2017-08-08 21:53 477 查看
Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

Consider the following algorithm:

input n

print n

if n = 1 then STOP

if n is odd then n ←− 3n + 1

else n ←− n/2

GOTO 2

Given the input 22, the following sequence of numbers will be printed

22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1, 000, 000 (and, in fact, for many more numbers than this.)

Given an input n, it is possible to determine the number of numbers printed before and including the 1 is printed. For a given n this is called the cycle-length of n. In the example above, the cycle length of 22 is 16.

For any two numbers i and j you are to determine the maximum cycle length over all numbers between and including both i and j.

Input

The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers

will be less than 10,000 and greater than 0.

You should process all pairs of integers and for each pair determine the maximum cycle length over

all integers between and including i and j.

You can assume that no operation overflows a 32-bit integer.

Output

For each pair of input integers i and j you should output i, j, and the maximum cycle length for

integers between and including i and j. These three numbers should be separated by at least one space

with all three numbers on one line and with one line of output for each line of input. The integers i

and j must appear in the output in the same order in which they appeared in the input and should be

followed by the maximum cycle length (on the same line).

Sample Input

1 10

100 200

201 210

900 1000

Sample Output

1 10 20

100 200 125

201 210 89

900 1000 174

题意:对于任意一个整数n,如果n是偶数,令n等于n/2,;如果n是奇数,令n等于3n+1,知道n的值为1。循环的次数即为此循环的长度,在给定的区间内找出这个区间内的最大长度。

方法:这道题的方法很简单,就是依次计算这区间内的所有整数,找出最大的长度的那个值;题目的陷阱在于没有说明所给的区间i和j谁大谁小,所有必须先进行判断;另外一个就是可能会产生溢出问题,所有推荐使用long long类型

#include <iostream>

using namespace std;

long long calculateNum(long long);

int main()
{
long long st, ed;
while(cin >> st >> ed){
long long maxLength = -1;
cout << st << " " << ed << " ";
if(st > ed){
long long temp = st;
st = ed;
ed = temp;
}
for(long long i = st; i <= ed; i++){
long long length = calculateNum(i);
maxLength = maxLength > length ? maxLength : length;
}
cout << maxLength << endl;
}
return 0;
}

long long calculateNum(long long n){
long long length = 1;
while(n != 1){
if(n % 2 == 0)
n /= 2;
else
n = 3 * n + 1;
length++;
}
return length;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  uva