您的位置:首页 > 其它

hdu 5973 大数威佐夫博弈

2017-08-05 09:20 387 查看
Problem Description

Two people face two piles of stones and make a game. They take turns to take stones. As game rules, there are two different methods of taking stones: One scheme is that you can take any number of stones in any one pile while the alternative is to take the same amount of stones at the same time in two piles. In the end, the first person taking all the stones is winner.Now,giving the initial number of two stones, can you win this game if you are the first to take stones and both sides have taken the best strategy?

Input

Input contains multiple sets of test data.Each test data occupies one line,containing two non-negative integers a andb,representing the number of two stones.a and b are not more than 10^100.

Output

For each test data,output answer on one line.1 means you are the winner,otherwise output 0.

Sample Input

2 1

8 4

4 7

Sample Output

0

1

0

题解:

JAVA大数还不是很熟练。参考了别人的代码。

学习了BigDecimal.toBigInteger把BigDecimal转化为BigDecimal方法。

代码:

import java.math.BigDecimal;
import java.math.BigInteger;
import java.util.Scanner;

public class 威佐夫博弈 {

public static void main(String[] args){

BigDecimal gr = new BigDecimal("1.618033988749894848204586834365638117720309179805762862135448622705260462818902449707207204189391137");

BigDecimal a2,b2;
BigInteger a,b,t,k2;
BigDecimal k;
Scanner s = new Scanner(System.in);

while(s.hasNext()){
a = s.nextBigInteger();
b = s.nextBigInteger();
if(a.compareTo(b)<0){
t=a;
a=b;
b=t;
}
a2 = new BigDecimal(a);
b2 = new BigDecimal(b);

k = a2.subtract(b2);
k = k.multiply(gr);
k2 = k.toBigInteger();

if(k2.compareTo(b)==0){
System.out.println("0");
}else{
System.out.println("1");
}

}

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: