您的位置:首页 > 其它

2017杭电多校联赛第二场-Funny Function (hdu6050)快速幂解数学方程

2017-07-27 16:21 337 查看


Funny Function

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 0    Accepted Submission(s): 0


Problem Description

Function Fx,ysatisfies:



For given integers N and M,calculate Fm,1 modulo
1e9+7.

 

Input

There is one integer T in the first line.

The next T lines,each line includes two integers N and M .

1<=T<=10000,1<=N,M<2^63.

 

Output

For each given N and M,print the answer in a single line.

 

Sample Input

2
2 2
3 3

 

Sample Output

2
33

题目大意:给你n,m,求f(m,1)





由矩阵快速幂解决。

ac代码:
// F(m,1)=(2*k1^(m-1)+(1+(-1)^(m+1))/2)/3 其中k1=(2^n-1);
#include <iostream>
#include <iostream>
#include <algorithm>
#include <stdio.h>
using namespace std;
const long long mod = 1e9+7;
long long f(long long x,long long k)
{
if (k==0) return 1;
if (k&1)
{
return f(x,k-1)*x%mod;
}else {
long long t=f(x,k/2);
return t*t%mod;
}
}
void exgcd(long long a,long long b,long long &x,long long &y)
{
if (!b) {
x=1;y=0;
return;
}
exgcd(b,a%b,y,x);
y-=x*(a/b);
}
long long x,y;
int main()
{
int T;
exgcd(3,mod,x,y);
x=(x+mod)%mod;
long long n3=x;
scanf("%d",&T);
while (T--)
{
long long n,m;
scanf("%I64d%I64d",&n,&m);
long long k1=(f(2,n)-1+mod)%mod;
long long tmp1=2*f(k1,m-1)%mod;
if (n&1)
{
printf("%I64d\n",(tmp1+1+mod)%mod*n3%mod);
}else printf("%I64d\n",tmp1*n3%mod);
}
}
题目链接:点击打开链接http://acm.hdu.edu.cn/showproblem.php?pid=6050
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: