您的位置:首页 > 其它

hdu1213--How Many Tables

2017-07-26 16:00 274 查看

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 32081    Accepted Submission(s): 15968


[align=left]Problem Description[/align]
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want
to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

 

[align=left]Input[/align]
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked
from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

 

[align=left]Output[/align]
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

 

[align=left]Sample Input[/align]

2
5 3
1 2
2 3
4 5

5 1
2 5

 

[align=left]Sample Output[/align]

2
4

 
思路   一道模板题  就这样

#include<iostream>
#include<cmath>
#include<cstring>
#include<vector>
#include<stdlib.h>
#include<stdio.h>
#include<algorithm>
#include<map>
#include <set>
#include <list>
#include <deque>
#include<sstream>
#include<time.h>
#define pi  3.1415926
using namespace std;
typedef long long ll;

int father[1005];
int find1(int n)
{
if(father
==n)
return n;
else
return father
=find1(father
);
}

int main()
{
int t,k=0;
scanf("%d",&t);
while(k!=t)
{
k++;
char s[10];
int n,m;
scanf("%d %d",&n,&m);
memset(father,0,sizeof(father));
for(int i=1;i<=n;i++)
father[i]=i;
int ans=0;
for(int i=0;i<m;i++)
{
int a,b,c,d;
scanf("%d %d",&a,&b);
c=find1(a);
d=find1(b);
if(c!=d)
{
father[c]=d;
}
}
for(int i=1;i<=n;i++)
if(father[i]==i)
ans++;
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  并查集