您的位置:首页 > 其它

HDU1896 Stones【模拟+优先队列】

2017-07-25 21:50 225 查看

Stones

Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)

Total Submission(s): 3015    Accepted Submission(s): 1951

[align=left]Problem Description[/align]
Because of the wrong status of the bicycle, Sempr begin to walk east to west every morning and walk back every evening. Walking may cause a little tired, so Sempr always play some games this time. 

There are many stones on the road, when he meet a stone, he will throw it ahead as far as possible if it is the odd stone he meet, or leave it where it was if it is the even stone. Now give you some informations about the stones on the road, you are to tell
me the distance from the start point to the farthest stone after Sempr walk by. Please pay attention that if two or more stones stay at the same position, you will meet the larger one(the one with the smallest Di, as described in the Input) first.

Input
In the first line, there is an Integer T(1<=T<=10), which means the test cases in the input file. Then followed by T test cases. 

For each test case, I will give you an Integer N(0<N<=100,000) in the first line, which means the number of stones on the road. Then followed by N lines and there are two integers Pi(0<=Pi<=100,000) and Di(0<=Di<=1,000) in the line, which means the position
of the i-th stone and how far Sempr can throw it.

Output
Just output one line for one test case, as described in the Description.

Sample Input

2
2
1 5
2 4
2
1 5
6 6

Sample Output

11
12

Author
Sempr|CrazyBird|hust07p43
Source
HDU 2008-4 Programming
Contest

问题链接HDU1896 Stones

问题简述

  Sempr走在路上时会玩一种游戏,遇见奇数块石头时将其扔到更远,遇到偶数块石头时则离开。问Sempr不会再遇到石头时,总共走了多少距离。

问题分析

  Sempr走在路上时,必然先遇到距离近的石头,所以需要用优先队列来表示问题。剩下的就是模拟走路的过程。

程序说明:(略)

题记:(略)

参考链接:(略)

AC的C++语言程序如下:

/* HDU1896 Stones */

#include <iostream>
#include <queue>
#include <stdio.h>

using namespace std;

struct _node {
int pos;
int dist;
friend bool operator <(const _node &a,const _node &b) {
if(a.pos == b.pos)
return a.dist > b.dist;
else
return a.pos > b.pos;
}
};

int main()
{
int t, n;

scanf("%d", &t);
while(t--) {
priority_queue <_node> q;
_node t;

scanf("%d", &n);
for(int i=1; i<=n; i++) {
scanf("%d%d", &t.pos, &t.dist);
q.push(t);
}

bool odd = true;
while(!q.empty()) {
t = q.top();
q.pop();

if(odd) {       // 奇数时操作
t.pos += t.dist;
q.push(t);
}
odd = !odd;
}

printf("%d\n", t.pos);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: