您的位置:首页 > 其它

POJ 2406 Power Strings 求最小循环节数(KMP)

2017-07-25 20:06 495 查看

Power Strings

Time Limit: 3000MS Memory Limit: 65536K

Total Submissions: 49380 Accepted: 20571

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = “abc” and b = “def” then a*b = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd

aaaa

ababab

.

Sample Output

1

4

3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

思路:

简单题贴个链接

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;

const int N = 1000005;

int nxt
;
char s
;
int len;

void calcnext() {
int i = 0, j = -1;
nxt[0] = -1;
while(i < len) {
if(j == -1 || s[i] == s[j]) {
i++, j++;
nxt[i] = j;
}
else
j = nxt[j];
}
}

int main(){
while( scanf("%s", s) > 0 ){
if( s[0] == '.' ) break;
len = strlen(s);
calcnext();
if( len % ( len - nxt[len] ) == 0 )
printf("%d\n", len / (len - nxt[len]));
else
printf("1\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: