您的位置:首页 > 产品设计 > UI/UE

Windows Message Queue

2017-07-25 10:17 113 查看
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.


Input

There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.


Output

For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.


Sample Input

GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET


Sample Output

EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!


#include<stdio.h>
#include<queue>
using namespace std;
typedef long long ll;
typedef struct node
{
char message[10];
int priority;
int parameter;
int id;
//划重点
friend bool operator <(node a,node b)
{
if(a.priority==b.priority)
return a.id > b.id;
return a.priority>b.priority;
}
}Node;
Node command[60010];
int main()
{
priority_queue<Node> pq;
char str[10];
int cnt=1;
while(~scanf("%s\n",str))
{
// getchar();
if(str[0]=='G')
{
if(pq.empty())
{
printf("EMPTY QUEUE!\n");continue;
}
printf("%s %d\n",pq.top().message,pq.top().parameter);
pq.pop();
}
else
{
scanf("%s",command[cnt].message);
//字符串中连续的输入,遇见空格就结束,然后转到下一个变量的输入,也可以直接 scanf("%s %d %d",......);
scanf(" %d %d",&command[cnt].parameter,&command[cnt].priority);
command[cnt].id=cnt;
pq.push(command[cnt]);
cnt++;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  优先队列