您的位置:首页 > 其它

POJ 2528 Mayor's posters (线段树 区间更新+离散化)

2017-07-22 21:36 489 查看
Mayor's posters

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 65645 Accepted: 18967
Description
The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city
council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 
Every candidate can place exactly one poster on the wall. 

All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 

The wall is divided into segments and the width of each segment is one byte. 

Each poster must completely cover a contiguous number of wall segments. 

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates
started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 

Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 

Input
The first line of input cont
4000
ains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines
describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers li and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively.
We know that for each 1 <= i <= n, 1 <= li <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered li, li+1 ,... , ri. 

Output
For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 



Sample Input
1
5
1 4
2 6
8 10
3 4
7 10


Sample Output
4


题意:
给你无限长的广告牌,给你n个广告和他们放置的位置,按照输入数据的顺序放置前后,问你能看见几个广告,看见一部分也算。

POINT:
先离散化,但是如果直接按照顺序去离散化,理论上是错的,但是可以AC.

如果你AC了 这组数据必然过不了
1
3
1 10
1 3
6 10

正确是3 但是只当你算出来是2的时候你才能A
为什么呢
因为4-5这段区间离散化的时候并没有处理到

区间保存的是被第几个广告完全覆盖,有多个广告则是零,这题折磨了我很久。



更悲催的是明明已经AC了,我却看成WA又检查了20分钟!!!

#include <iostream>
#include <stdio.h>
#include <math.h>
#include <map>
#include <string.h>
#include <algorithm>
#include <fstream>
using namespace std;
#define lt 2*x
#define rt 2*x+1
#define LL long long
const int N  = 22000*5;
int b[N/5];
int col
,fl
;
struct node
{
int l,r;
}a[N/5];
void pushdown(int x)
{
fl[lt]=fl[x];
fl[rt]=fl[x];
col[lt]=fl[x];
col[rt]=fl[x];
fl[x]=0;

}
void add(int x,int l,int r,int ll,int rr,int i)
{
if(fl[x]) pushdown(x);
if(ll<=l&&rr>=r)
{
col[x]=i;
fl[x]=i;
}
else
{
int mid=(l+r)>>1;
if(ll<=mid) add(lt,l,mid,ll,rr,i);
if(mid<rr) add(rt,mid+1,r,ll,rr,i);
if(col[lt]==col[rt]) col[x]=col[rt];
else col[x]=0;
}
}
int vis
;
int query(int x,int l,int r)
{
if(fl[x]) pushdown(x);
int ans=0;
if(col[x]||l==r)
{
if(!vis[col[x]])
{
vis[col[x]]=1;
ans++;
}
}
else
{
int mid=(l+r)>>1;
ans+=query(lt,l,mid);
ans+=query(rt,mid+1,r);
}
return ans;

}
int main()
{
int T;
scanf("%d",&T);
while(T--)
{
int n;
scanf("%d",&n);
memset(b,0,sizeof b);
memset(col,0,sizeof col);
memset(fl,0,sizeof fl);
int cnt=0;
for(int i=1;i<=n;i++)
{
scanf("%d %d",&a[i].l,&a[i].r);
b[++cnt]=a[i].l;
b[++cnt]=a[i].r;
}
sort(b+1,b+1+cnt);
int m=unique(b+1,b+1+cnt)-b-1;
for(int i=1;i<=n;i++)
{
a[i].l=lower_bound(b+1,b+m+1,a[i].l)-b;
a[i].r=lower_bound(b+1,b+m+1,a[i].r)-b;
}
for(int i=1;i<=n;i++)
{
add(1,1,m,a[i].l,a[i].r,i);
}
memset(vis,0,sizeof vis);
int ans=query(1,1,m);
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: