您的位置:首页 > 其它

AtCoder Regular Contest 078-C - Splitting Pile

2017-07-16 00:47 330 查看

C - Splitting Pile

Time limit : 2sec / Memory limit : 256MB

Score : 300 points

Problem Statement

Snuke and Raccoon have a heap of N cards. The i-th card from the top has the integer ai written on it.

They will share these cards. First, Snuke will take some number of cards from the top of the heap, then Raccoon will take all the remaining cards. Here, both Snuke and Raccoon have to take at least one card.

Let the sum of the integers on Snuke’s cards and Raccoon’s cards be x and y, respectively. They would like to minimize |x−y|. Find the minimum possible value of |x−y|.

Constraints

2≤N≤2×105

−109≤ai≤109

ai is an integer.

Input

Input is given from Standard Input in the following format:

N

a1 a2 … aN

Output

Print the answer.

Sample Input 1

Copy

6

1 2 3 4 5 6

Sample Output 1

Copy

1

If Snuke takes four cards from the top, and Raccoon takes the remaining two cards, x=10, y=11, and thus |x−y|=1. This is the minimum possible value.

Sample Input 2

Copy

2

10 -10

Sample Output 2

Copy

20

Snuke can only take one card from the top, and Raccoon can only take the remaining one card. In this case, x=10, y=−10, and thus |x−y|=20.

题目大意:有一个序列,A取前若干个,B取剩余的,问所取数之和的差值的绝对值的最小值是多少?

解题思路:计算前缀和,扫一遍即可

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
typedef long long LL;
const int MAXN=2e5+5;
const int MOD=1000000000;
const LL INF=(2e5)*(1e9)+5;
LL a[MAXN];
LL sum[MAXN];

int main()
{
ios::sync_with_stdio(false);
int n;
while(cin>>n)
{
LL tot=0;
for(int i=1;i<=n;i++)
{
cin>>a[i];
sum[i]=sum[i-1]+a[i];
tot+=a[i];
}
LL Min=INF;
for(int i=1;i<n;i++)
{
if(Min>abs(2*sum[i]-tot))
Min=abs(2*sum[i]-tot);
}
cout<<Min<<endl;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: