您的位置:首页 > 其它

【HDU 2647】Reward (邻接表实现拓扑排序,反向排序)

2017-07-14 23:36 495 查看
Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards. 

The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward
will be at least 888 , because it's a lucky number.

InputOne line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000) 

then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.
OutputFor every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.
Sample Input
2 1
1 2
2 2
1 2
2 1


Sample Output
1777
-1


这道题不过不用邻接表会爆内存,这道题没必要一定可以进行排序,只要没有环就可以

wa了好多发就因为把不可以排序的情况也输出了-1

例如:

n = 3, m = 2;

1 2

1 3

显然这没法排序,但只要1的工资同时比2和3都低就可以按题意输出工资

而且反向排序可以简单的完成判断输出所需的最大工资

AC代码:

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<cstdio>
#include<queue>
#include<vector>
using namespace std;
const int MX = 10005;
int n, m, tot, ind, sum, head[MX], IN[MX], mo[MX];
struct Edge{
int v, nxt;
}e[2 * MX];
void add(int u, int v)
{
e[tot].v = v;
e[tot].nxt = head[u];
head[u] = tot++;
IN[v]++;
}
void init(){
memset(head, -1, sizeof(head));
memset(IN, 0, sizeof(IN));
tot = 0;
ind = 0;
sum = 0;
}
bool topo_sort(){
queue<int> q;
for(int i = 1; i <= n; i++)
{
if(IN[i] == 0)
q.push(i);
}
while(!q.empty()){
int v = q.front();
sum += mo[v];
q.pop();
ind++;
for(int i = head[v]; ~i; i = e[i].nxt){
int u = e[i].v;
IN[u]--;
if(IN[u] == 0)
{
q.push(u);
mo[u] = mo[v] + 1;
}
}
}
if(ind != n)
{
return false;
}
return true;
}
int main()
{
int u, v;
while(scanf("%d%d", &n, &m) != EOF){
init();
fill(mo, mo + n +1, 888);
for(int i = 0; i < m; i++)
{
scanf("%d%d", &u, &v);
add(v, u);
}
if(topo_sort()){
cout<<sum<<endl;
}
else
cout<<-1<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: