您的位置:首页 > 其它

hdu2845—Beans(dp)

2017-07-13 14:33 393 查看
题目链接:传送门


Beans

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4967    Accepted Submission(s): 2325


Problem Description

Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following
rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.



Now, how much qualities can you eat and then get ?

 

Input

There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M*N<=200000.

 

Output

For each case, you just output the MAX qualities you can eat and then get.

 

Sample Input

4 6
11 0 7 5 13 9
78 4 81 6 22 4
1 40 9 34 16 10
11 22 0 33 39 6

 

Sample Output

242

 

解题思路:先对行dp获取每一行能获得的最大元素和,再对列dp,获取整个矩形中最大的元素和。行和列的动态转移方程都是dp[i] = max(dp[i-1],dp[i-2]+data[i])

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#include <string>
#include <stack>
#include <queue>

using namespace std;

typedef long long ll;
typedef pair<int,int>PA;
const int N = 120;
const int M = 200119;
const int INF = 0x3fffffff;

int data[M],row[M],column[M];
//先对行进行dp,再对列进行dp
//column[i]:对某一行,在第i个位置能获得的最大sum
//row[i]:对所有列,在第i列能获得的最大sum

int main()
{
int n,m;
while( ~scanf("%d%d",&n,&m) ){
for( int i = 2 ; i <= n+1 ; ++i ){
column[0] = column[1] = 0;
for( int j = 2 ; j <= m+1 ; ++j ){
scanf("%d",&data[j]);
column[j] = max( column[j-1] , column[j-2]+data[j] );
}
row[i] = column[m+1];
}
row[0] = row[1] = 0;
for( int i = 2 ; i <= n+1 ; ++i ){
row[i] = max( row[i-1] , row[i]+row[i-2] );
}
printf("%d\n",row[n+1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: