您的位置:首页 > 产品设计 > UI/UE

PAT (Advanced Level) Practise 1099 Build A Binary Search Tree (30)

2017-07-03 14:52 531 查看


1099. Build A Binary Search Tree (30)

时间限制

100 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node's key.
The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence
of that tree. The sample is illustrated by Figure 1 and 2.



Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format "left_index right_index",
provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.
Sample Input:
9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:
58 25 82 11 38 67 45 73 42


题意:给你一个固定好了的有n个节点的树,给你n个值,将它们插入树中,使得树是一棵二叉搜索树解题思路:按照中序遍历将数字从小到大插入即可

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#include <vector>
#include <queue>
#include <stack>
#include <map>
#include <set>
#include <cmath>

using namespace std;

#define LL long long
const int INF = 0x3f3f3f3f;

int n,now[105][5],cnt,a[105],ans[105];

void dfs(int k)
{
if(now[k][0]!=-1) dfs(now[k][0]);
ans[k]=a[cnt++];
if(now[k][1]!=-1) dfs(now[k][1]);
}

int main()
{
while(~scanf("%d",&n))
{
for(int i=0;i<n;i++) scanf("%d%d",&now[i][0],&now[i][1]);
for(int i=0;i<n;i++) scanf("%d",&a[i]);
sort(a,a+n);
cnt=0;
dfs(0);
queue<int>q;
q.push(0);
while(!q.empty())
{
int pre=q.front();
q.pop();
printf("%s%d",pre?" ":"",ans[pre]);
if(now[pre][0]!=-1) q.push(now[pre][0]);
if(now[pre][1]!=-1) q.push(now[pre][1]);
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: