您的位置:首页 > 其它

5-51 两个有序链表序列的合并 (20分)

2017-06-22 14:39 197 查看
5-51 两个有序链表序列的合并   (20分)

已知两个非降序链表序列S1与S2,设计函数构造出S1与S2的并集新非降序链表S3。

输入格式:

输入分两行,分别在每行给出由若干个正整数构成的非降序序列,用-1−1表示序列的结尾(-1−1不属于这个序列)。数字用空格间隔。

输出格式:

在一行中输出合并后新的非降序链表,数字间用空格分开,结尾不能有多余空格;若新链表为空,输出
NULL

输入样例:

1 3 5 -1
2 4 6 8 10 -1

输出样例:

1 2 3 4 5 6 8 10

#include<iostream>
#include<cstdlib>
using namespace std;
typedef struct linknode* List;
struct linknode
{
int data;
List next;
};
List Create()
{
List L=(List)malloc(sizeof(struct linknode));
L->data=-1;
L->next=NULL;
return L;
}
int main()
{
List L=Create();
List p=L;
int t;
while(cin>>t)
{
if(t==-1)
break;
List temp=(List)malloc(sizeof(struct linknode));
temp->data=t;
temp->next=NULL;
p->next=temp;
p=p->next;
}
List LL=L;
while(cin>>t)
{
if(t==-1)
break;
List temp=(List)malloc(sizeof(struct linknode));
temp->data=t;
temp->next=NULL;
while(!(t>=LL->data&&((LL->next!=NULL&&t<=LL->next->data)||LL->next==NULL)))
{
LL=LL->next;
}
List hh=LL->next;
LL->next=temp;
temp->next=hh;
}
L=L->next;
if(L==NULL)
{
cout<<"NULL"<<endl;
return 0;
}
while(L!=NULL)
{
if(L->next==NULL)
{
cout<<L->data<<endl;
}
else
{
cout<<L->data<<" ";
}
L=L->next;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: