您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表七:单链表中重复元素的删除

2017-06-10 19:49 218 查看
按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。

Input

第一行输入元素个数 n (1 <= n <= 15);

第二行输入 n 个整数,保证在 int 范围内。

Output

第一行输出初始链表元素个数;

第二行输出按照逆位序所建立的初始链表;

第三行输出删除重复元素后的单链表元素个数;

第四行输出删除重复元素后的单链表。

Example Input

10

21 30 14 55 32 63 11 30 55 30

Example Output

10

30 55 30 11 63 32 55 14 30 21

7

30 55 11 63 32 14 21

Hint

Author

不得使用数组!

@思路解析:

首先,根据题目大意可知,此题可用倒序建立链表的方式,并不得使用数组。

其次,题目中还要求删除重复元素,并且要注意计算重复元素的个数。

此题目代码实现:

#include <stdio.h>
#include<stdlib.h>
#include<string.h>
struct node
{
int data;
struct node * next;
};
struct node * creat(struct node * head, int n)
{
while(n--)
{
struct node *p;
p=(struct node *)malloc(sizeof(struct node));
scanf("%d", &p->data);
p->next = head->next;
head->next = p;
}
return head;
};
void show(struct node *head)
{
struct node *p = head->next;
while(p)
{
while(p->next)
{
printf("%d ",p->data);
p = p->next;
}
printf("%d\n", p->data);
p = NULL;
}
}
int Del(struct node *head, int n)
{
struct node *p, *q, *r;
p = head->next;
while(p)
{
q = p->next;
r = p;
while(q)
{
if(p->data==q->data)
{
if(q->next)
{
r->next = q->next;
free(q);
q = r->next;
n--;
}
else
{
r->next = NULL;
free(q);
q = NULL;
n--;
}
}
else
{
r = r->next;
q = q->next;
}
}
p = p->next;
}
return n;
}
int main()
{
int n;
scanf("%d", &n);
printf("%d\n",n);
struct node *head;
head = (struct node *)malloc(sizeof(struct node));
head->next = NULL;
head = creat(head, n);
show(head);
printf("%d\n", Del(head, n));
show(head);
return 0;
}

/***************************************************
User name:
Result: Accepted
Take time: 0ms
Take Memory: 108KB
Submit time:
****************************************************/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  单链表
相关文章推荐