您的位置:首页 > 其它

poj 2586 Y2K Accounting Bug Time Limit

2017-05-17 23:24 357 查看
题目

Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 15170 Accepted: 7595

Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc.

All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite.

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

Input

Input is a sequence of lines, each containing two positive integers s and d.

Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

Sample Input

59 237

375 743

200000 849694

2500000 8000000

Sample Output

116

28

300612

Deficit

#include<iostream>
#include<algorithm>

using namespace std;

int profit(int s,int d){
if(d>4*s) return -2*d+10*s;
if(2*d>3*s) return -4*d+8*s;
if(3*d>2*s) return -6*d+6*s;
if(4*d>s) return -9*d+3*s;
else return -1;
}

int main(){
int s ,d;
while(cin >>s >>d){
int sum = profit(s,d);
if(sum>=0) cout<< sum<<endl;
else cout<<"Deficit"<<endl;
}
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: