您的位置:首页 > 其它

PAT-A-1074. Reversing Linked List (25)

2017-05-15 00:10 344 查看


1074. Reversing Linked List (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K = 3, then you must output 3→2→1→6→5→4; if K = 4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (<= 105) which is the total number of nodes, and a positive K (<=N) which is the length of the sublist
to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<stdio.h>

using namespace std;

const int maxn = 100010;

struct Node
{
int add,date;
int next;
int order;

}node[maxn];

int cmp(Node a, Node b)
{
return a.order < b.order;
}
int main()
{
int begin, n, k;
int add;

for (int i = 0; i < maxn; i++)
node[i].order = maxn;

cin >> begin >> n >> k;

for (int i = 0; i < n; i++)
{
cin >> add;
cin >> node[add].date >> node[add].next;
node[add].add = add;
}

int cnt = 0;
int p;

for (p = begin; p != -1; p = node[p].next)
node[p].order=cnt++;

sort(node, node + maxn, cmp);

for (int i = 0; i < cnt / k; i++)
{
for (int j = (i + 1)*k - 1; j>i*k; j--)
{
printf("%05d %d %05d\n", node[j].add, node[j].date, node[j - 1].add);

}

printf("%05d %d ", node[i*k].add, node[i*k].date);

if (i < cnt / k - 1)
printf("%05d\n", node[(i + 2)*k - 1].add);

else
{
if (cnt%k == 0)
cout << "-1" << endl;
else
{
printf("%05d\n", node[(i + 1)*k].add);

for (p = (i + 1)*k; p < cnt; p++)
{
if (p<cnt-1)
printf("%05d %d %05d\n", node[p].add, node[p].date, node[p].next);
else
printf("%05d %d -1\n", node[p].add, node[p].date);

}

}
}
}
system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: