您的位置:首页 > 其它

hdu 5137 How Many Maos Does the Guanxi Worth(最短路)

2017-04-27 21:22 302 查看
上题:
"Guanxi" is a very important word in Chinese. It kind of means "relationship" or "contact". Guanxi can be based on friendship, but also can be built on money. So Chinese often say "I don't have one mao (0.1 RMB) guanxi with
you." or "The guanxi between them is naked money guanxi." It is said that the Chinese society is a guanxi society, so you can see guanxi plays a very important role in many things.

Here is an example. In many cities in China, the government prohibit the middle school entrance examinations in order to relief studying burden of primary school students. Because there is no clear and strict standard of entrance, someone may make their children
enter good middle schools through guanxis. Boss Liu wants to send his kid to a middle school by guanxi this year. So he find out his guanxi net. Boss Liu's guanxi net consists of N people including Boss Liu and the schoolmaster. In this net, two persons who
has a guanxi between them can help each other. Because Boss Liu is a big money(In Chinese English, A "big money" means one who has a lot of money) and has little friends, his guanxi net is a naked money guanxi net -- it means that if there is a guanxi between
A and B and A helps B, A must get paid. Through his guanxi net, Boss Liu may ask A to help him, then A may ask B for help, and then B may ask C for help ...... If the request finally reaches the schoolmaster, Boss Liu's kid will be accepted by the middle school.
Of course, all helpers including the schoolmaster are paid by Boss Liu.

You hate Boss Liu and you want to undermine Boss Liu's plan. All you can do is to persuade ONE person in Boss Liu's guanxi net to reject any request. This person can be any one, but can't be Boss Liu or the schoolmaster. If you can't make Boss Liu fail, you
want Boss Liu to spend as much money as possible. You should figure out that after you have done your best, how much at least must Boss Liu spend to get what he wants. Please note that if you do nothing, Boss Liu will definitely succeed.
 

[align=left]Input[/align]

There are several test cases.

For each test case:

The first line contains two integers N and M. N means that there are N people in Boss Liu's guanxi net. They are numbered from 1 to N. Boss Liu is No. 1 and the schoolmaster is No. N. M means that there are M guanxis in Boss Liu's guanxi net. (3 <=N <= 30,
3 <= M <= 1000)

Then M lines follow. Each line contains three integers A, B and C, meaning that there is a guanxi between A and B, and if A asks B or B asks A for help, the helper will be paid C RMB by Boss Liu.

The input ends with N = 0 and M = 0.

It's guaranteed that Boss Liu's request can reach the schoolmaster if you do not try to undermine his plan.
 

[align=left]Output[/align]

For each test case, output the minimum money Boss Liu has to spend after you have done your best. If Boss Liu will fail to send his kid to the middle school, print "Inf" instead.
 

[align=left]Sample Input[/align]

4 5
1 2 3
1 3 7
1 4 50
2 3 4
3 4 2
3 2
1 2 30
2 3 10
0 0

 

[align=left]Sample Output[/align]

50
Inf

题意 就是一张图,告诉你有n个点和m条边,和权值,之后你可以删除一个点,问你删除那个点,可以得到从1到n最短路的最大值,如果删除的那个点之后无法到达n的话就输出Inf  。
思路 可以看出最多只有30个点,floyd可以直接暴力过去的,做法就是 ,每次删除一个点吗,那就让和这个点连通的路的权值全部变成INF,之后利用floyd就好了,复杂度算是o(N^3),如果加上链式前向星和spfa的话可能会更快,但是看了一下,floyd就可以0s水过了,点太少了对了比较坑的地方在于这个路是双向的 双向的!
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f
int map[35][35],map1[35][35];
int n,m;
void floyd()
{
for(int k=1;k<=n;k++)
{
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
if(map1[i][j]>map1[i][k]+map1[k][j])
{
map1[i][j]=map1[i][k]+map1[k][j];
}
}
}
}
}
int main()
{

int a,b,c;
while(scanf("%d%d",&n,&m),n||m)
{
int flag=0;
memset(map,INF,sizeof(map));
for(int i=0;i<m;i++)
{
scanf("%d%d%d",&a,&b,&c);
if(map[a][b]>c)
{
map[a][b]=map[b][a]=c;
}
}
int MAX=0;
for(int k=2;k<=n-1;k++)//删除点的操作
{
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
if(i==k||j==k)
{
map1[i][j]=INF;
map1[j][i]=INF;
}
els
a936
e
{
map1[i][j]=map[i][j];
}
}
}
floyd();
if(map1[1]
==INF)
{
flag=1;
break;
}
else
{
MAX=max(map1[1]
,MAX);
}
}
if(flag)
{
printf("Inf\n");
}
else
{
printf("%d\n",MAX);
}
}
}


下面上代码
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: