您的位置:首页 > 其它

nyoj1277 Decimal integer conversion (河南省acm第九届省赛)

2017-04-27 16:01 369 查看


题目1277

题目信息

运行结果

本题排行

讨论区


Decimal integer conversion

时间限制:1000 ms  |  内存限制:65535 KB
难度:2

描述XiaoMing likes mathematics, and he is just learning how to convert numbers between different bases , but he keeps making errors since he is only 6 years old. Whenever XiaoMing converts a number to a new base and writes down
the result, he always writes one of the digits wrong. For example , if he converts the number 14 into binary (i.e., base 2), the correct result should be "1110", but he might instead write down "0110" or "1111". XiaoMing never accidentally adds or deletes
digits, so he might write down a number with a leading digit of " 0" if this is the digit she gets wrong. Given XiaoMing 's output when converting a number N into base 2 and base 3, please determine the correct original value of N (in base 10). (N<=10^10)
You can assume N is at most 1 billion, and that there is a unique solution for N. 

输入The first line of the input contains one integers T, which is the nember of test cases (1<=T<=8)

Each test case specifies:

* Line 1: The base-2 representation of N , with one digit written incorrectly.

* Line 2: The base-3 representation of N , with one digit written incorrectly.
输出For each test case generate a single line containing a single integer , the correct value of N

样例输入
1
1010
212


样例输出
14


来源河南省第九届省赛
上传者onlinejudge题意就是小明将一个十进制的数转化为2进制或者三进制的时候总会错一个数字  求这个十进制数。暴力即可

水题一枚

#include <stdio.h>
#include <string.h>
#include <math.h>
char a[105];
char b[105];
long long getnum(char *c,int x,int len)
{
long long res=0;
for(int i=0;i<len;i++)
{
res+=(c[i]-'0')*pow(x,len-i-1);
}
return res;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
memset(a,0,sizeof(a));
memset(b,0,sizeof(b));
scanf("%s",a);
scanf("%s",b);
int len1=strlen(a);
int len2=strlen(b);
char ch1,ch2;
long long num1,num2;
int find=-1;
for(int i=0;i<len1;i++)
{
ch1=a[i];
if(a[i]=='0') a[i]='1';
else a[i]='0';
num1=getnum(a,2,len1);
// printf("num1=%d\n",num1);
for(int j=0;j<len2;j++)
{
ch2=b[j];
b[j]='0';
if(ch2!=b[j])
{
num2=getnum(b,3,len2);
if(num1==num2)
{
find=num1;
break;
}
}
if(find!=-1) break;
b[j]='1';
if(ch2!=b[j])
{
num2=getnum(b,3,len2);
if(num1==num2)
{
find=num1;
break;
}
}
if(find!=-1) break;
b[j]='2';
if(ch2!=b[j])
{
num2=getnum(b,3,len2);
if(num1==num2)
{
find=num1;
break;
}
}
b[j]=ch2;
}
if(find!=-1)
{
break;
}
a[i]=ch1;
}
printf("%d\n",find);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: