您的位置:首页 > 其它

POJ 1118 Lining Up

2017-04-23 18:07 225 查看
Lining Up

Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 25423 Accepted: 7973
Description

"How am I ever going to solve this problem?" said the pilot. 

Indeed, the pilot was not facing an easy task. She had to drop packages at specific points scattered in a dangerous area. Furthermore, the pilot could only fly over the area once in a straight line, and she had to fly over as many points as possible. All points
were given by means of integer coordinates in a two-dimensional space. The pilot wanted to know the largest number of points from the given set that all lie on one line. Can you write a program that calculates this number? 

Your program has to be efficient! 

Input

Input consist several case,First line of the each case is an integer N ( 1 < N < 700 ),then follow N pairs of integers. Each pair of integers is separated by one blank and ended by a new-line character. The input ended by N=0.
Output

output one integer for each input case ,representing the largest number of points that all lie on one line. 
Sample Input
5
1 1
2 2
3 3
9 10
10 11
0

Sample Output
2
这道题目与2606题比较相似,也是根据输入的点,求一条直线上可以包含的最多的点的数目。注意输入,0比较重要,它是可以循环进行案例的测试
#include <iostream>
#include <cstdio>
using namespace std;
#define N 1000
#define up(i,a,b) for(int i=a;i<=b;i++)
struct node{
int x,y;
};

int main(int argc, const char * argv[]) {
int n;
node t[700];
while(scanf("%d",&n)&&n)//循环输入n,若n等于0,则停止。保证了可以循环进行案例的测试
{
for(int i=0;i<n;i++)
scanf("%d %d",&t[i].x,&t[i].y);
int max=0;
for(int i=0;i<n;i++)
for(int j=i+1;j<n;j++)
{
int sum=0;
for(int k=j+1;k<n;k++)
{
if((t[i].y-t[j].y)*(t[i].x-t[k].x)==(t[i].y-t[k].y)*(t[i].x-t[j].x))
sum++;
}
if(sum>max)
max=sum;
}
cout<<max+2<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: