您的位置:首页 > 产品设计 > UI/UE

hdu1711_Number Sequence_(KMP的数组用法)

2017-04-22 18:36 351 查看

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 25906    Accepted Submission(s): 10951


[align=left]Problem Description[/align]
Given two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M].
If there are more than one K exist, output the smallest one.

 

[align=left]Input[/align]
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate
a[1], a[2], ...... , a
. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

 

[align=left]Output[/align]
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

 

[align=left]Sample Input[/align]

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

 

[align=left]Sample Output[/align]

6
-1

题意:给你两个数组,需要你求出第二个数组在第一个数组中首次出现的位置,是从第一个数组中第几个数字开始的。

解: KMP套用,将char类型换成int类型就ok了,

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <algorithm>

using namespace std;
const int maxn=1e6+5;
int pl,sl;int s[maxn],p[maxn];int next1[maxn];int sum;
void get_next()
{
int k=-1,j=0;
next1[0]=-1;
while(j<pl)
{
if(k==-1||p[j]==p[k])
{
j++;k++;
next1[j]=k;
}
else
k=next1[k];
}
}
int KMP()
{
int i=0,j=0;
get_next();
while(j<pl&&i<sl)
{
if(j==-1||s[i]==p[j])
{
i++;j++;
}
else j=next1[j];
if(j==pl)
{
sum=i-pl+1;j=next1[j];
break;
}
}
return sum;
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
sum=-1;
scanf("%d%d",&sl,&pl);
for(int i=0;i<sl;i++)
scanf("%d",&s[i]);
for(int i=0;i<pl;i++)
scanf("%d",&p[i]);
int ans=KMP();
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: