您的位置:首页 > 产品设计 > UI/UE

UVA 133 The Dole Queue 【约瑟夫环】

2017-04-20 19:04 316 查看

题面:

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros

Party has decided on the following strategy. Every day all dole applicants will be placed in a large

circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counterclockwise

up to N (who will be standing on 1’s left). Starting from 1 and moving counter-clockwise,

one labour official counts off k applicants, while another official starts from N and moves clockwise,

counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick

the same person she (he) is sent off to become a politician. Each official then starts counting again

at the next available person and the process continues until no-one is left. Note that the two victims

(sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already

selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0,

0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of

three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each

number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counterclockwise

official first. Separate successive pairs (or singletons) by commas (but there should not be a

trailing comma).

Note: The symbol ⊔ in the Sample Output below represents a space.

Sample Input

10 4 3

0 0 0

Sample Output

␣␣4␣␣8,␣␣9␣␣5,␣␣3␣␣1,␣␣2␣␣6,␣10,␣␣7

题目大意:

一共有n个人,坐成一个环。以1-n逆时针编号。有两个人A,B。A从1开始数k个人,B从n开始数m个人。被数到的人退场。然后继续数,直到所有人都退场。

输出退场次序,若A与B数的人编号不同,A数的先输出。

大致思路:

开一个数组保存编号。退场的编号为0,数到0的时候跳过。记得对A取膜,B小于零时变为n。

代码:

#include<bits/stdc++.h>
using namespace std;
bool isempty(int *s,int n)//判断是否全部退场
{
for(int i=1;i<=n;++i)
if(s[i]!=0)
return true;
return false;
}
int main()
{
int n,k,m;
int s[21];
while(cin>>n>>k>>m&&(n||k||m))
{
int a=1,b=n,cnt=1;
for(int i=1;i<=n;++i)
s[i]=i;
while(isempty(s,n))
{
if(cnt!=1)
printf(",");
int ca=1,cb=1;
while(ca!=k||cb!=m)
{
if(ca<k){
a++;
if(a>n)
a%=n;
if(s[a]!=0)
ca++;
}
if(cb<m){
b--;
if(b<1)
b=n;
if(s[b]!=0)
cb++;
}
//  cout<<ca<<" "<<cb<<endl;
}
if(a!=b)
printf("%3d%3d",s[a],s[b]);
else
printf("%3d",s[a]);
s[a]=s[b]=0;
if(isempty(s,n)){//数到人退场之后的a,b指针处理
while(s[a]==0)
{
++a;
if(a>n)
a=1;
}
while(s[b]==0)
{
--b;
if(b<1)
b=n;
}
}
cnt++;
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  uva