您的位置:首页 > 其它

poj 2155 Matrix(二维树状数组)(经典)

2017-04-19 18:11 351 查看

Matrix

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using “not” operation (if it is a ‘0’ then change it into ‘1’ otherwise change it into ‘0’). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).

Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format “Q x y” or “C x1 y1 x2 y2”, which has been described above.

Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.

Sample Input

1

2 10

C 2 1 2 2

Q 2 2

C 2 1 2 1

Q 1 1

C 1 1 2 1

C 1 2 1 2

C 1 1 2 2

Q 1 1

C 1 1 2 1

Q 2 1

Sample Output

1

0

0

1

ps:搞了好久,终于弄明白了,大致就是分两种方法

方法一:更新上界,求点下界

这种方法的主要思想可以参考浅谈信息学竞赛中的“0”和“1”,多看几遍就会懂了

代码:

#include<stdio.h>
#include<string.h>

#define maxn 1010
int mp[maxn][maxn];
int n,m;

int lowbit(int x)
{
return x&-x;
}

void change(int x,int y)
{
for(int i=x; i<=n; i+=lowbit(i))
for(int j=y; j<=n; j+=lowbit(j))
mp[i][j]=(mp[i][j]+1)&1;
}

int getsum(int x,int y)
{
int sum=0;
for(int i=x; i>0; i-=lowbit(i))
for(int j=y; j>0; j-=lowbit(j))
sum+=mp[i][j];
return sum&1;
}

int main()
{
int t;
scanf("%d",&t);
while(t--)
{
memset(mp,0,sizeof(mp));
scanf("%d%d",&n,&m);
char op[5];
int x1,y1,x2,y2;
for(int i=0; i<m; ++i)
{
scanf("%s",op);
if(op[0]=='C')
{
scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
++x1,++y1,++x2,++y2;
change(x2,y2);
change(x1-1,y2);
change(x2,y1-1);
change(x1-1,y1-1);
}
else
{
scanf("%d%d",&x1,&y1);
printf("%d\n",getsum(x1,y1));
}
}
puts("");
}
return 0;
}


方法二:更新下界,求点上界

思路:

传统的树状数组是改变某个点,然后查询某一段,而这个题是改变某一段,查询某个点,所以这里只需要进行一下转换,将原来的改值变成查询,查询变成改值。改值时相当于对区间分别进行修改,而查询某个点时,就是将覆盖这个点的区间全加起来,然后把一维的改成二维的就可以了。

这种方法不用把坐标++了

代码:

#include<stdio.h>
#include<string.h>

#define maxn 1010
int mp[maxn][maxn];
int n,m;

int lowbit(int x)
{
return x&-x;
}

int getsum(int x,int y)
{
int sum=0;
for(int i=x; i<=n; i+=lowbit(i))
for(int j=y; j<=n; j+=lowbit(j))
sum+=mp[i][j];
return sum&1;
}

void change(int x,int y)
{
for(int i=x; i>0; i-=lowbit(i))
for(int j=y; j>0; j-=lowbit(j))
mp[i][j]=(mp[i][j]+1)&1;
}

int main()
{
int t;
scanf("%d",&t);
while(t--)
{
memset(mp,0,sizeof(mp));
scanf("%d%d",&n,&m);
char op[5];
int x1,y1,x2,y2;
for(int i=0; i<m; ++i)
{
scanf("%s",op);
if(op[0]=='C')
{
scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
change(x2,y2);
change(x1-1,y2);
change(x2,y1-1);
change(x1-1,y1-1);
}
else
{
scanf("%d%d",&x1,&y1);
printf("%d\n",getsum(x1,y1));
}
}
puts("");
}
return 0;
}


参考博客:1.小媛在努力~ 2.3214668848

总结:开始时想到了对区间内的每一个点+1%2就是反转,但是还是没有想到通过统计区间内有多少个点进行了改变来判断当前点是否改变这种方法,而且也不知道该让哪些区间内的点进行改变。

总之,学到了很多,也容易忘,还是要经常回顾这种思想的!
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: